Validating transactions, but I've contributed 0.0000 Sol/s and completed 0 Equihash solver runs

Hello all!

I am very new to cryptocurrencies and mining, so please bear with me.

I left zcash running for over 20 hours, and it says that I've completed 40 transactions, which is of course to be expected. However, it says that I've contributed 0.0000 Sol/s on average, and I've completed 0 Equihash solver runs.

Is this supposed to happen? Or is there something wrong with my configuration of zcash?

Thanks so much for your help!

Edit: I've figured out what the issue was. In my .conf file for zcash I had the "genproclimit" set incorrectly. So, I correctly set it to the amount of cores in my CPU.

Do you have gen=1 in your zcash.conf?

Follow the guide section "Enabling CPU mining"

Yes, I have that in my .conf file! The issue was that I followed the instructions and added, genproclimit=$(nproc) in my file manually instead of from the command line. I noticed this and manually added the correct amount of cores in my machine and it seems to be working really well now!

I have same issue. genproclimit inserted correctly. Have no idea why I have 0.0000sol/s

But that's solo mining. Isn't it?

Solomining depedns a lot on luck. It is a lottery.
Mining for a pool gives you a more steady revenue as you contrubute with shares to the poolnetwork.

At the current network difficulty you need about one month (33 days) worth of mining with 1000 Sol/s (thats like 8 RX470 graphiccards atm) to find a block. On average. You could also mine forever with 1000Sol/s without finding something.

Yes, it's solo. Just to try. The problem is 0.0000Sol/s I can't understand why. It should give some.

Oh yes, that’s strange.

I get some Sol/s running with the daemon.

But performance is bad anyway.
I get about 30 Sol/s on that machine with nheqminer.

Check this thread for more info.

The client is still downloading the block chain. Once the block chain is downloaded the mining will start.

I would try just setting genproclimit=4 or however many # cores you want to run rather than the genproclimit=$(nproc) argument.

1 Like