Set up your own private stratum pool


#181

I've created a domain for my Zcash stratum pool ninjapool.org Port 3357
Fee is set at 0%

ZecMiner64.exe -zpool ninjapool.org:3357 -zwal taddress.workername -zpsw x

I've added a ssl certificate to the nginx configuration by using this configuration
./configure --prefix=/home/user/nginx --add-module=/home/user/ZEC/ngxrest --with-http_ssl_module --with-http_v2_module

I think there are still things to resolve like the difficulty. If you have any pointers, please do share.
Currently there is over 5500 hash/s, need a bit more to find a block.


#182

Hey.... congratulations :))) glad you got it all working!!!

I will update the guide to add the SSl part :wink:

and for the difficulty setting, I haven't got anything yet for that !!

and ... will test your pool now :smiley:


#183

Thank you. I don't have much time, I'm supposed to be writing papers, but find this much more interesting.
To get a free SSL cert (must be renewed every 60-90 days) I used this guide.

In our case, since we installed nginx to our home user directory the server block file is not /etc/nginx/sites-available/default, but rather /home/user/nginx/conf/nginx.conf

the guide references the web root as being /var/www/html, but in our case it should be /home/user/nginx/html
Other key things is that we will need to add a snippets directory with the following files inside it:
/home/user/nginx/conf/snippets
sudo nano /home/user/nginx/conf/snippets/ssl-example.com.conf
sudo nano /home/user/nginx/conf/snippets/ssl-params.conf

And to test the nginx.conf you do not need to start or stop the service, goto /home/user/nginx/sbin/ and run
sudo ./nginx -t

I'd have to look at things more, but we may want to restrict read/write permissions on some of the folders and files to only the owner. The node and daemons might be vulnerable to being hacked.


#184

Hi.

Is there a way to see what t-add are conected to pool and mining?


#185

I haven't looked into that ... maybe if you query the database files .. which i haven't learned yet how to do :))


#186

Did you get an answer yet? I've tried using MRR as well with the same results. Flypool & Nicehash work fine, but the pools from this source.. not yet.


#187

Do they work with zogpool?


#188

No.. tried on zogpool & luckpool with no success.


#189

then it could be like optiminer ... you know that optiminer does not work with eXtermal's code?!


#190

No, but maybe I'll try to use a rig that specifically says SilentArmy or Claymore and see what I get


#191

Started a campaign
https://forum.zcashcommunity.com/t/reward-campaign-hunt-for-block-pool-northernminers-com-this-weekend/12621


#192

These pools are p2pool, not supported on MRR.


#193

Tried a Claymore rental rig too, no go. A setting on MRR. Claymore on my personal rigs, sending the shares way too fast on my pool, difficulty way too low.


#194

eXtremal pools are not p2pools. They do not connect in anyway over a peer to peer overlay network. P2pool is something completely different that I'm working on next perhaps.

I don't know why managed mining rigs (I'm assuming something like toomim?) can't connect to the pool.

One thing you could try is watching the incoming stratum messages (or just generally debugging) from the MMR. I don't have one of those contracts so I can't test.


#195

Ok, help me understand why these are not p2pool.
1 there are lots of p2p files/code in these pool. aren't those p2pool?
2 they are running the zcash node which is peer to peer, correct?
3 node shows a peer count.
4 or is it very similar to a p2pool?
4 or did I just set up zcash for this pool wrong?


#196

no messages, just says the pool is broken and won't connect.


#197

"p2p" systems are often used in \database schemes such as paxos or riak. eXtremal just used a custom lib called "p2p" to connect the database with "clients" or pools (zcash, xmr, eth,...)

This is a nice way to allow multiple pools to write concurrently to the same db as well perhaps easily distribute a cluster for pool failover on the server. (something I have struggled with on zogpool). But I am uncertain how eXtremal deploys his "frontends"

As for your questions I would say good old fashion research into p2p systems is a good start.


#198

Is it me or the guide from the first post does not contain information on how to create the zcash.conf file? zcashd didn't would just exit immediately after starting, until I created the ~./zcash/zcash.conf file
Or maybe I did something wrong in the previous steps?


#199

No you are correct... the guide missed the part of the zcash.conf... will update it as soon as I get to my laptop... thank you @voidwalkerz9 :))

Updated :)))


#200

OK so after a few hours of hassle I got everything up and working, following your guide + the zcash.conf file creation. The only problem is I don't receive any jobs from the pool. Tried connecting with claymore to 192.168.x.y:19999, it says it connected but does not receive any jobs, after a while it says job timeout. Also in the pool screen i get 0 workers 0 gpus etc. HELP