Set up your own private stratum pool


#161

Are you running the script or manually starting zcashd?

Sorry I'm on my mobile phone so I couldn't see the previous post... I could ssh later when I get home and take a look at you setup if you want!

If so just pm me


#162

@megacrypto
I run the script , now i removed ./root , and its ok , it connected.
thanks for help.


#163

yes of course :))) if you are on root then it should not be in the path .... sorry i missed that ... was reading off my mobile !!!

glad you got it working :)))


#164

now I am able to connect , but no new job received. my server does not send jobs to miner. any idea why ?
is there any test i have to do ?


#165

when you connect to the pool ("screen -r zecpool") do you see it picking up the new incoming blocks? it should every minute or so say something like "new block xxxxx ....." or something like that (i dont have it running right now so i cant really get you the exact msg it says")


#166

@megacrypto

loaded 0 shares from shares.raw file
loaded 0 payouts from payouts.raw.old file
loaded 0 payouts from payouts.raw file
loaded 0 rounds from db
loaded 0 user balance data from db
* found partition ~/pool.zcash/workerStats/2016.12 for ~/pool.zcash/workerStats
* found partition ~/pool.zcash/poolstats/2016.12 for ~/pool.zcash/poolstats
: Pool backend started, mode is MASTER
: Pool fee of 1% to t1uuxxxxxxxxxxxxxxxxxxxxxxxxx
totalQueued: 0
totalRequested: 0
getBlockTemplate call failed
i think i found something.:
when I run :

root@localhost:~/poolcore/x86_64-Linux/poolrpccmd# ./poolrpccmd p2p://127.0.0.1:12201 getinfo
I get :
Error: connecting error

and when I ping my public Ip from the terminal , it doesn't find it.
so i think i have routing problem.


#167

i think the frontend is able to connect to the zcashd ...

in the bash script can you change the config files path to the absolute path ... i believe yours should be something like:

/usr/bin/screen -dmS "zecpool" ./ZEC/pool_frontend_zcash/x86_64-Linux/pool_frontend_zcash /root/.zcash/zcash.cfg

and also for the poolrestapi line


#168

@megacrypto
thanks for all your help. finally it worked.
i used this batch ffile

 #!/bin/bash
   ./zcash/src/zcashd -p2pport=12201
   ./pool_frontend_zcash/x86_64-Linux/pool_frontend_zcash /root/.zcash/zcash.cfg
  ./poolrestapi/x86_64-Linux/poolrestapi /root/.zcash/poolrestapi.cfg
   sudo /home/streamview/nginx/sbin/nginx

now i will move the web interface :slight_smile:


#169

Screenshots anyone of a successul run here on this, thinking and reading. Got both slaves up and running now so might as well form a pool too :wink:


#170

you can always check it live running stable on www.zogpool.org :wink:


#171

I was about to say that or just scroll up on all of the awesome SS you have posted in this thread. Great job btw with all of this. Running zogpool has not been easy.

Advise:

  • Use a crontab to restart the rest api ~every 5-10 minutes (it crashes often)
  • Crontab a script to check to make sure the pool_frontend_zcash proc is running every minute and start it if not.
  • I havent done a check for zcashd to be alive and reboot but zcashd has only crashed i think once on me in two weeks.

Cheers


#172

Can someone explain why a mining rig rental rig cannot connect to this pool. I rent rigs when I need a little more hash power at times. I tried to connect 2 of them to my pool and they will not connect. Rental site checks the address & connection string and are ok, but cannot connect the rigs "broken pool", so I end up pointing somewhere else. My personal rigs in & out of network and other miner rigs connect fine. Rigs from https://www.miningrigrentals.com/rigs/equihash can't connect to the pool. Anyone know why?


#173

your personal rigs are within your network, right?

can you post your pool's address ... I can see if i would connect?!


#174

what is the minimum hardware requirement, a VPS with 1GB RAM is enough or not?


#175

Thanks dear OP this is pretty well laid out!


#176

dont think that 1GB is enough ... as far as i understand the zcashd needs some RAM to be able to process payment transactions in a timely manner ... i run mine with 4GB


#177

The requirements say that you need 4gb ram and I think 2 cpu cores.

However, mine is running on digital ocean and got 512 mb ram instance.
I created a 5 gb swap file and enabled it (ssd). A 3.5 -4gb swap should be all you really need.

sudo sysctl vm.swappiness=10

It takes a little longer to install, but my pool seems to be working fine and is quite responsive. I'd have to look at memory and cpu usage more to determine if the physical ram is really necessary.
Alas, even with 4-5k sols/s no blocks found. :frowning: This stratum setup would be awesome for Ethereum solo mining, so I may add that feature.
A little heads up is that it initially took me a good day to figure out this guide. Even as someone who has setup lamp, pxe and many other linux servers in the past. Megacrypto did an amazing job, regardless.


#178

If you do that, I hope you share it with us :)))))


#179

Doesn't this pool default with ETH support? Comes with Etc, XPM, and ZEC already.

http://coinsforall.io/#!/coin/ETC

ETC should run the same as ETH. Just boot up a wallet and give it a try.


#180

Will give it a try and see how it goes :))