Set up your own private stratum pool


#101

i might have missed this part in the steps ... just realized that

  • rename or copy a few files to match the "ZEC" changes

mv /home/user/nginx/html/static/s/templates/zcash-description.html /home/user/nginx/html/static/s/templates/zec-description.html
mv /home/user/nginx/html/static/s/templates/zcash-mining.html /home/user/nginx/html/static/s/templates/zec-mining.html
mv /home/user/nginx/html/static/s/templates/zcash-servers.html /home/user/nginx/html/static/s/templates/zec-servers.html

apologies !!!


#102

Oh! Thanks!
That's the right column part I've been missing!
Wondering why It didnt aprears! It was just the name! Zcash - Zec.
Ty again :slight_smile:

Still waiting for hit a block ^^ lets see if I can get some more hashing power :smiley:


#103

Also.. I see in zogpool, he has the :slight_smile:

Pool Solution Rate
Equihash:
3878.393 sols/s

But my pool just says "comming soon"

You know how to make that part works?


#104

Could I set this up on an AWS instance?


#105

Can u share how zcash.conf should look maybe here is the problem at me


#106

When I do
sudo apt-get install cmake libssl-dev libsodium-dev libpcre3-dev libleveldb-dev libboost-all-dev libgmp-dev libprotobuf-dev protobuf-compiler libjansson-dev screen build-essential pkg-config libc6-dev m4 g ++ - multilib autoconf libtool ncurses-dev unzip git python zlib1g-dev wget bsdmainutils automake

Could not find a package libsodium-dev


#107

You have to play around with the in the static files ( in /home/user/nginx/html/static/s/templates folder ) ... this one i believe will be the coins.html file

i honestly don't know

here you go:

addnode=mainnet.z.cash
rpcuser=your rpc user name
rpcpassword=your rpc password

are you on Ubuntu 16?


#108

Ubuntu 14.04.5 LTS ......................


#109

i would suggest google "ubuntu 14.04 install libsodium-dev" because as far as i know, there are some major changes between ubuntu 14 and 16!!!


#110

Thank You Megacrypto
I successfully compile all, the problem turned out indeed to be completely sync block
and validation of transactions in the menu zcashd.if it all is running perfectly,
certainly not a problem.I often compile error because the Internet is not stable.i use ubuntu 15.10


#111

Thanks. So good...........


#112

In the last step:
adminko@ub:~/ZEC/pool_frontend_zcash/x86_64-Linux$ make -j4
[ 14%] Running C++ protocol buffer compiler on /home/adminko/ZEC/pool_frontend_zcash/src/protocol.proto
Scanning dependencies of target pool_frontend_zcash
[ 28%] [ 42%] [ 57%] [ 71%] [ 85%] Building CXX object CMakeFiles/pool_frontend_zcash.dir/main.cpp.o
Building CXX object CMakeFiles/pool_frontend_zcash.dir/zcashpool.cpp.o
Building CXX object CMakeFiles/pool_frontend_zcash.dir/zmtp.cpp.o
Building CXX object CMakeFiles/pool_frontend_zcash.dir/equihash_original.cpp.o
Building CXX object CMakeFiles/pool_frontend_zcash.dir/stratum.cpp.o
[100%] Building CXX object CMakeFiles/pool_frontend_zcash.dir/protocol.pb.cc.o
In file included from /home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.cpp:1:0:
/home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.h:83:3: error: ‘set’ in namespace ‘std’ does not name a type
std::set uniqueShares;
^
In file included from /home/adminko/ZEC/pool_frontend_zcash/src/main.cpp:1:0:
/home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.h:83:3: error: ‘set’ in namespace ‘std’ does not name a type
std::set uniqueShares;
^
/home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.cpp: In function ‘void onShare(poolContext*, pool::proto::Request&, pool::proto::Reply&, bool*)’:
/home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.cpp:212:17: error: ‘struct poolContext’ has no member named ‘uniqueShares’
if (!context->uniqueShares.insert(shareHeaderHash).second) {
^
/home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.cpp: In function ‘int64_t stratumCheckShare(poolContext*, aioObject*, StratumMessage*, uint256*, const char**, int64_t*)’:
/home/adminko/ZEC/pool_frontend_zcash/src/zcashpool.cpp:389:17: error: ‘struct poolContext’ has no member named ‘uniqueShares’
if (!context->uniqueShares.insert(*shareHeaderHash).second) {
^
/home/adminko/ZEC/pool_frontend_zcash/src/main.cpp: In function ‘void* timerProc(void*)’:
/home/adminko/ZEC/pool_frontend_zcash/src/main.cpp:332:14: error: ‘struct poolContext’ has no member named ‘uniqueShares’
ctx->uniqueShares.clear();
^
/home/adminko/ZEC/pool_frontend_zcash/src/main.cpp: In function ‘void signalHandler(p2pPeer*, void*, size_t, void*)’:
/home/adminko/ZEC/pool_frontend_zcash/src/main.cpp:454:16: error: ‘struct poolContext’ has no member named ‘uniqueShares’
context->uniqueShares.clear();
^
make[2]: *** [CMakeFiles/pool_frontend_zcash.dir/zcashpool.cpp.o] Ошибка 1
make[2]: *** Ожидание завершения заданий…
make[2]: *** [CMakeFiles/pool_frontend_zcash.dir/main.cpp.o] Ошибка 1
make[1]: *** [CMakeFiles/pool_frontend_zcash.dir/all] Ошибка 2
make: *** [all] Ошибка 2


#113

The command /usr/bin/screen -dmS "zecnode" ./ZEC/zcash/src/zcashd not lead to any action


#114

This is a dependency error, you are using ubuntu 14...I didn't use 14....if possible use a fresh copy with ubuntu server 16


#115

This command should start a "screen" session running the node in it. Type:

screen -r zecnode

This should get you in the screen session of zecnode


#116

Have you figured out reason for this error yet?

I get the same thing every time I run


#117

It's not an error type screen -r zecnode an u;ll see the pool runing in the backend


#118

I know, I see it running and the web is up. I'm trying to figure why that line is there and if it is a error of some type in nginx. Does not feel right to me. I'll dig some more.


#119

@solved rebuild all again.


#120

change "user" to your user name.