Setting up mining at a pool


#1

So I have spent the better part of this weekend setting up my new rig for the sole purpose of mining.

Disclaimer: I have a love/hate relationship with linux and need some serious step by step

I have Zcash rpc running.

CONF =
Testnet=1
addnode=betatestnet.z.cash
rpcuser=user
rpcpassword=password
gen=1

Is this still correct for the newest Zcash RPC?

Second,

I have tried to follow instructions for NHequiminer to set up on both supernovas and coinmine, to no avail.

I get this everytime with NH

~/nheqminer/build$ qmake ../nhequiminer/nheqminer.pro
qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No such file or directory

Someone point me in the right direction please. I am trying to be ready for friday as the rest of us are,

thank you


#2

CPU mining or GPU mining?
Solo or pool mining ?


#3

I have AMD cards, so unless I missed a GPU miner being available CPU for now


#4

To install and get running:

sudo apt-get upgrade

sudo apt-get update

sudo apt-get install \
build-essential pkg-config libc6-dev m4 g++-multilib \
autoconf libtool ncurses-dev unzip git python \
zlib1g-dev wget bsdmainutils automake

git clone https://github.com/zcash/zcash.git
cd zcash/
git checkout v1.0.0-rc2

./zcutil/fetch-params.sh

./zcutil/build.sh -j$(nproc)

./qa/zcash/full-test-suite.sh

mkdir -p ~/.zcash

nano ~/.zcash/zcash.conf

testnet=1
addnode=betatestnet.z.cash
rpcuser=username
rpcpassword=password
genproclimit=numberofcores
gen=1
equihashsolver=tromp

ctrl-x
y - enter
enter

~/zcash/./src/zcashd -daemon

This should get you mining on tromps solvers


#5

./src/zcash-cli stop
error: {"code":-28,"message":"Activating best chain..."}

currently getting this


#6

This is after i ran "./src/zcashd -reindex

"


#7

cd zcash/
make clean
git fetch origin
git checkout v1.0.0-rc2
./zcutil/fetch-params.sh

rm -rf ~/.zcash/testnet3


#8

i am seriously about to wipe it and start over


#9

best thing to do is wipe when you have major issues

I also wipe it out each new version that comes out.


#10

git checkout v1.0.0-rc2
HEAD is now at 90c116a... Add release notes and Debian changelog entry.


#11

Yeah Im just gonna wipe it damn it


#12

I'd been getting exactly the same error message. According to the accepted answer to this SE question it indicates that the node hasn't started up yet and it may take a few minutes. For me, waiting two hours had no effect, so I have wiped and rebuilt the whole thing and zcashd is now starting up alright.
I have yet to figure out how to connect it to the pool, but that's a topic for another post...


#13

On the number of cores if I have a 8 core cpu i put 8 correct?


#14

yes but 75% usually is faster so 6


#15

I cant figure out the whole pool thing, solo i got down, but thats pointless


#16

For testing pool mining use this
https://github.com/sarath-hotspot/zcash/wiki

and run

src/zcash-miner -genproclimit=numberofcores -stratum=stratum+tcp://zec.suprnova.cc:2142 -user=username.worker -password=yourpass -debug -printtoconsole

It's the same solvers


#17

@trolloniex I got that working yesterday, but the wiki got updated and now states:

"Update: DO NOT USE THIS FORK. Changes in this fork are integrated into official zcash build. Use following command with official build to run tromp solver for mining. zcashd -daemon -equihashsolver=tromp"

However, when I build the "official" one, there's no zcash-miner binary anywhere. So I am kind of stuck.


#18

Let me test one of my miners to see if I can get it running on the official zcashd.


#19

I rebuilt the entire thing only to get the same errors

~/zcash/./src/zcashd -daemon
Zcash server starting
:~/zcash$ Error: An error occurred while setting up the RPC address 127.0.0.1 port 18232 for listening: bind: Address already in use
Error: Unable to bind to 0.0.0.0:18233 on this computer. Bitcoin Core is probably already running.
Error: Failed to listen on any port. Use -listen=0 if you want this.
./src/zcash-cli stop
error: incorrect rpcuser or rpcpassword (authorization failed)
:~/zcash$
:~/zcash$ ./src/zcash-cli stop
error: incorrect rpcuser or rpcpassword (authorization failed)
~/zcash$ ./src/zcash-cli stop
error: {"code":-28,"message":"Activating best chain..."}
:~/zcash$


#20

BTW it works in official zcashd

~/zcash/./src/zcashd -daemon -stratum=poolstratum -user=username.worker -password=yourpass -debug -printtoconsole

NOTE: Suprnova is running on another chain so it wont work