Setting up mining at a pool

What are you using as username and pass ?

testnet=1
addnode=betatestnet.z.cash
rpcuser=username
rpcpassword=password
genproclimit=6
gen=1
equihashsolver=tromp

the previous version before i wiped everything was different, which i tried changing to that as well and nothing worked. I am literaly about to wipe linux and reinstall that too

This is what works for me:
rpcuser=rpcusername
rpcpassword=rpcpassword

One last attempt than I am wiping linux to god damn it

Not sure if wiping your Linux is going to make a difference.
If you want to try what process is listening on port 18232, use
netstat -plant | grep 18232.
If the ./src/zcash-cli stop is not working for you (I had that when I was experimenting with -reindex) - just kill the damn thing (kill -9 PID).

"code":-28,"message":"Activating best chain... is usually the chain waiting to sync

Leave it running for a minute then test

currently running ./qa/pull-tester/rpc-tests.sh,

netstat -plant | grep 18232 seemed to have worked, but i still had to enter listen=0 after

NOPE

~/zcash$ ~/zcash/./src/zcashd -daemon
Zcash server starting
~/zcash$ Error: An error occurred while setting up the RPC address 127.0.0.1 port 18232 for listening: bind: Address already in use
Error: Unable to bind to 0.0.0.0:18233 on this computer. Bitcoin Core is probably already running.
Error: Failed to listen on any port. Use -listen=0 if you want this.
listen=0
:~/zcash$ ~/zcash/./src/zcashd -daemon
Zcash server starting
:~/zcash$ Error: An error occurred while setting up the RPC address 127.0.0.1 port 18232 for listening: bind: Address already in use
Error: Unable to bind to 0.0.0.0:18233 on this computer. Bitcoin Core is probably already running.
Error: Failed to listen on any port. Use -listen=0 if you want this.
kill-9 PID
kill-9: command not found
:~/zcash$ kill-9 PID
kill-9: command not found
~/zcash$ kill-9 PID)
bash: syntax error near unexpected token `)'
~/zcash$ (kill-9 PID)
kill-9: command not found
krztoff2202@krztof2202:~/zcash$

What version of linux are you running?

and have you

sudo apt-get upgrade
sudo apt-get update

16.04 Ubuntu, did that as well

I feel like there was something a miss so I deleted EVERYTHING, I am currently reinstalling Linux.

Hello, krztoff5150:

Try with this:

http://cdimage.debian.org/debian-cd/8.6.0/amd64/iso-cd/debian-8.6.0-amd64-CD-1.iso

When you get it and installed into your pc, then follow the next two links,
first to zcash wallet
second to the best cpu miner

https://github.com/zcash/zcash/wiki/Beta-Guide

https://github.com/sarath-hotspot/zcash/wiki

If you want mining from your zcash wallet your zcash.conf must be similar to:

testnet=1
addnode=betatestnet.z.cash
rpcuser=Invent_A_username
rpcpassword=Invent_A_password
gen=1

If you want mining from your cpu at a pool like zmine.io your zcash.conf must be similar to:

testnet=1
addnode=betatestnet.z.cash
rpcuser=Invent_A_username
rpcpassword=Invent_A_password

See the homepage of zmine.io for the miner command.

The best regards and wishes, ask again if you don't get the final objetive, mining.

@krztoff5150
The command is kill -9 PID
where PID is a process ID of the process you're killing. Note the space between kill and -9

ps aux
will give you the list of running processes.

Seems like most of my issue was not taking the time to verify commands. Above where trollinex tried to help me out, i didnt adjust the commands he laid out appropriately. Where some of them were on top of each other I copied more than one at a time or didnt copy enough of one command

In either case, I am back up and slowly running , I am running test now.

Conf file set to

testnet=1
addnode=betatestnet.z.cash
rpcuser=fpcusername
rpcpassword=rpcpassword

./zcash-standalone-miner/src/zcash-miner -stratum=stratum+tcp://zec.suprnova.cc:2142 -user=fpcusername.user -password=rpcpassword -debug -printtoconsole
bash: ./zcash-standalone-miner/src/zcash-miner: No such file or directory

No Joy

Help for pool settings?

@krztoff5150
why are you invoking a zcash-miner and not zcashd - have you built one of the forks? If so - which one?
Have you managed to run zcashd in a standalone mode yet?

Plus, according to @trolloniex:

"NOTE: Suprnova is running on another chain so it wont work"

I am about to chuck my pc out the window and burn it....So frustrating...

I am trying to use linux and get the latest (best h/s) cpu miner working but keep running into problems.

Is there anyone here that would be willing to make a step by step youtube video please???

Oh hell dude, I was at that so long yesterday I am not sure exactly what I am running as for the forks go. Now I did follow trollinex/ the beta guide. Than I installed the miner suggested by Cjx4q0iquv. After which I saw below not to use that fork and just run the equisolver=tromp line in the conf.

I did not remove the miner suggested by cjx4 from
https://github.com/sarath-hotspot/zcash/wiki

Do I need to remove it?

The stand alone settings show everything running perfect, at least to my knowledge. However pool settings, yeah that shit still confuses lol

Thanks for all y'alls help to by the way.

Ha ha I was there yesterday! Wipe it and start over bro. Go line by line. Linux is a bitch if you miss a single character

Driving me crazy man but I just started over again.

What speed are you getting with the new miner?