Superslow downloading of blocks and verification of transactions --Starting zcashd

Upon initiation of zcashd, the blocks are downloading and the transactions are verifying just fine.

But then at 23% (third try) and at 43% (first and second try) it slows down to almost nothing.

zcashd has been working 24/7 now.

Should I -reindex and or, and -rebuild one more time and let it work through it, even though it’s superslow?

I’d to like to know what I can do about this and get to mining some ZEC.

Thanks!

just give it time, it will sync. could take up to 24 hours

Could it be that the program is fluctuating and will speed up after a while?

There’s between one and three transaction-verifications per every fifth second.

Understand there’s millions verifications to go.

Alright, I will let it run through.

Even if it takes a whole week.

But honestly though. The software is shit. It is no way soft. Is there nothing the Team can do at this point?

1 Like

Its a big chain to download, and depending on your connection and how many nodes you’re connected to it could take a a day or so.

Try downloading bitcoin’s blockchain, it is 7 to 14 days

Yeah. But it was downloading fast up until a certain point, then it almost stopped.

zcashd

"

Downloading blocks | 107116 / 249410 (42%)
Connections | 8
Network solution rate | 68024002 Sol/s

Since starting this node 7 hours, 2 minutes, 40 seconds

  • You have validated 7914 Transactions!
  • You have completed 0 Equihash runs.

"

The block count has not moved an inch in 4 hours. Not one block!

What is up with that?

Btw.

Monero is not like this, or bitcoin for that matter.
Their software is downloading blocks steady and without stopping.

This will take a thousand days, at this pace, according to my calculations.

I’m not exaggerating. It’s rather not.

If you run native linux client I can assure you it could take weeks to syncronize the bitcoin blockchain.

What usually happens is that they provide the blocks syncronized to a certain point (usaully to the block of the day it has been uploaded).
You can download proving/verifying sprout keys of zcash and be only a couple of months behind. Here are the files from Jan 2017: https://twitter.com/radix42/status/824873220469780482

If anyone has a more updated version please post the link.

2 Likes

Seriously. This is not helping. At all.

It’s still on 42% and the same block.

This will take forever, damn it.

Is there not anyone that can help me?

Please- You’ve got the wrong idea. This is not about bitcoin. But zcash and its software ‘zcashd’.

Btw, I’ve been here since it all started back in 2009.

If you can’t help me with the actual problem, never mind commenting.

Thanks :blush:

And thanks for the hyperlink!:yum::yum: It’s appreciated.

Wait a minute. The hyperlink you provided is containing files for windows. correct?

I’m running Linux Mint 18.3 Sylvia for everything crypto.

Windows can kiss my butt :wink:

send me your bitcointalk profile link, or it never happend.

You didn’t specify your os, I would have never expected a linux user to have difficulty.

Anywhoes I believe .key files are used also in linux zcashd.
Anyways, I’ve got the main client on an ubuntu partition and it took 4-5 hours to sycronize to latest block. So your problem could be network related, what type of connection do you have (ethernet, wifi, mobile, speed, etc.), any firewalls? Did you try to remove and reinstall zcashd client?

1 Like

Yeah, It may be the network. But how come it is starting fine and wimps down to a almost absolute stop? I’d like to point out that this happened the first time I started the program and is happening everytime I execute the ‘-reindex’ command to start over. Only It seems that it is experiencing an anomaly. Varying each time when it stops at ‘=%’. First 43%, second 23%, third 42% and so on.

And you know . .

No expectations, no disappointments :wink: :wink:

mine has been stuck at block 246463 for about 12 hours.

2 Likes

Hey man!

It’s all working now. Zcash was simply not installed right. So I made it new from source.

All of this is still very strange though, because it was first installed utilizing the official 1.0 Guide with specific and highlighted commands.

My original installation was not done from any binary, but in fact gotten from the official repository of z.cash.

. . . . .

Here’s a list of steps I took to make it work properly:

  1. I deleted all related to zcash.
  2. I made new folders ‘.zcash’ and ‘.zcash-params’
  3. Downloaded new zcash files and compiled them anew from source

Profit$! :money_mouth_face::money_mouth_face::money_mouth_face:

PS ~ Me has big club and is very sorry for typo. But me like to smash and bash with club.

Mine works now too. I had to delete the contents of .zcash except for my wallet and redownload the blockchain. It took awhile but finally finished.

Every time I tried to sync the block-chain on the Zcash GUI, it froze at the 42% mark.
Use command prompt and enter “c:\Program Files\zcash4win\app\zcashd.exe” -damemon=0 -showmetrics=1
And let it load via command prompt, it will sync to 100%.
And If it stops, you can close command prompt and redo the command and it will restart where it froze.