Temp problems with 13x1080ti rigs

Hello !

Im new to the mining and finaly got my 3 Rigs set up each with 13x Aorus 1080ti - after having troubles with riser usb cables who where not working everything is running so far. But i have problems with the temp - some cards are around 83C° the rest would be ok-ish around 70°C ( Room temp was around 20°C id guess ) but they are not running at maxium Power because of the temp :(. I have never used linux befor and cant find any programs that would allow me to tweak / undervolt or set my fans to 100%.

So any advice? How are you guys keeping your cards cool? Is there some sort of Afterburner for Linux?

IMG_5439[1]!

Would you mind sending your entire rig hardware specifications?

Thanks.

Are the cards on the bottom getting the hottest? If so, it’s probably because the heat has nowhere to go.

I’m new to mining as well, but I would consider a more open frame design, as well as a way to push fresh air past the gpu’s. Notice how this frame is completely open and has fans on the front?

LOL, I’ve even seen people use a dial boxfan set up to push / pull hot air from the gpu’s, just to get more air circulation.

Btw, what is your has rate with that set up, and are you using the ASROCK H110 Pro btc+?

You need to turn fan 100% .

If i would know how to do that - id d that :wink: :smiley:

Sure,

  • 3x HX1200i Powersupply Plat 80+
  • 1x HX550i Powersupply
  • 1x ASRock H110 Pro BTC + Bitcoin ATX Mainb
  • 1x Intel Pentium G3900 (2x2.8 GHz) 2MB Vide
  • 1x 4GB (1x4GB) Crucial DDR4-2133 CL15 (15-1
  • 1x Kingston A400 120GB TLC 2.5zoll SATA600
  • 13x Gigabyte AORUS GeForce GTX 1080Ti 11GB G
  • 13x Riser from Amazon with 6Pin Power - They suck 10% didnt work ( USB Cable )

It was just a Pic - The rigs will not be stacked like this. But still i need to rearrange them and mount some fans so push the hot air away.

On ZCash the hashrate was around 9200sol

1 Like

Solid - what pool are you mining with?

You need to run an X server for each card in order to to use nvidia-settings. nvidia-settings will let you set watts, clock, mem, and fan.

Check out the scripts in cyclenerd’s (Ubuntu based) Nvidia OS or (easier if it works) just try to run that OS directly. I have it running with 8 1060s.

There will probably be a steepish learning curve if you’re new to linux.

I can recommend the nvoc customization of Ubuntu - we have 12 1080ti mining zcash with very little configuration required: https://bitcointalk.org/index.php?topic=1854250.0

Well everything is running so far - i still got some temp problems i need to fix by mounting the cards differently and ad alot of fans.

but i still cant figure out how to get coolbits to run - How do you run a Xserver for each card, every command i write in the xorg.conf is getting deleted after restart :frowning:.

Can’t see very well on this pic but, i think cards should have a little bit more space between them and make sure cards heat it’s not vented against each other. Also i think it’s normal cards in the middle to be with a little bit higher temp. I have rig with 6 cards and the 3 cards in the middle are always with higher temp compare to this that are 1st and last in the row.

This might help with Xorg.conf:

This is how cyclenerd sets up the “fake monitors”:

I used to install Ubuntu, everything is good except that I can’t find the setting to control the fan, the temp is always around nearly 80C, now I come back to Windows 10.

Did you try the nvoc mod? Easy to detect up to 13 gpus and control everything including fans. Link above.

So on the Ubuntu setup you’ll need to do the following:

If you only want to control power (undervolting or overvolting) then do:
sudo nvidia-smi -pl - where some number is what you want the voltage to be. I generally undervolt mine to 80% power but I run them in the 55-60 degree range only. If you want to see current info on the cards do sudo nvidia-smi and it will show baseline voltage settings. nvidia-smi -pm ENABLED -i X (where X is the instance number of the gpu) will enable persistence mode and make the changes stick across reboots. A quick google of nvidia-smi will help you.

If you want to control individual fan speeds, gpu and memory clocks you’ll have to do this:
Disable the gpumanager - I believe someone already posted you to a link on AskUbuntu. GPUManager is re-writing your xorg.conf at boot so that’s why you keep losing your changes for coolbits

The nvidia-settings utility is what allows you to control fan speeds per gpu, per gpu clocks and per gpu memory clocks. This utility will only control gpu’s that have been bound to an Xserver display. I believe someone above posted you a link to a guys script that will configure your xorg.conf for you that allows this. You’ll know your xorg.conf is right when you open nvidia-settings, look at the gpu’s and you have individual fan control. Be careful overclocking the gpu as the numbers are pluses to the baseline card performance so if it’s running at 2000 and you add +500 then it will crash the XServer (and the machine) because you overclocked it beyond the max. Linux won’t hold your hand and tell you it’s too much, it just gives up.

Hopefully that helps! Good luck mining.

Thanks,

a friend of mine came over, he knows linux - we managed to make the xorg.conf file stick, but when we add the coolbits 12 parameter, or any coolbits - it does nothing.

ok. Here is a sample xorg.conf that should bind 3 cards to 3 X server displays. Compare this to your xorg.conf file and see what differences you have. I also stay away from the nvidia-xconfig command as the xorg.conf it wrote for my rig never booted correctly.
Your BusID’s in the xorg.conf must match the actual PCI device numbers. You can get the bus id’s using the lspci command. You also need to have your device and screen sections to match (1 device section, 1 screen section) and then have an entry for them in ServerLayout.

Coolbits 28 allows all tuning options (fan control, gpu overclock and gpu memory overclock).

Before you do this copy your existing xorg.conf (which works) to xorg.conf_backup. Make changes to xorg.conf and reboot. If the system doesn’t come up, hit CTRL+ALT+F1 to get a console login. login, sudo to root and copy your backup file to xorg.conf, then reboot again. That should get the system back up in gui mode.

Section "ServerLayout"
Identifier "dual"
Screen 0 "Screen0"
Screen 1 “Screen1” RightOf "Screen0"
Screen 2 “Screen2” RightOf "Screen1"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:5:0:0"
Option “Coolbits” "28"
Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:6:0:0"
Option “Coolbits” "28"
Option "AllowEmptyInitialConfiguration"
EndSection

Section "Device"
Identifier "Device2"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BusID "PCI:9:0:0"
Option “Coolbits” "28"
Option "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
EndSection

Section "Screen"
Identifier "Screen2"
Device "Device2"
EndSection

Extend your rig frame to allow a box fan to be mounted to it. Point the fan so that it updrafts. (Sucks the heat from the cards and pulls it upwards.) This lowered my card temps by about 10-15C. My issue was that the output of one card was being sucked into the inlet of the next card. The box fan fixed this for less than $20.

Hope this helps.