Testnet Faucet from ZECpages

How about setting the rate limit to 75 seconds? You know, something about Zcash block time. :wink:


Thank you for submitting a second proposal @BrunchTime!

A question about this part of the budget:

Is this piece of the budget for work that has already been done? I don’t think if the answer is “yes” that’s a blocker, but I just wanted to be clear about it. It’s something that came up on another project too and we don’t really have a policy for it yet.

My sense is that, because it would be trivial for someone to conceal from us that work had already been done, we shouldn’t have a rule against funding work that has already been completed.

That said, it does seem different and I’m curious what others think. Perhaps we should think of funding pre-done work as a prize and be explicit about that?

Also, apologies if I’m misunderstanding—and again I think it’s okay either way!


Hey Holmes - Thanks for the question! I’m happy to clarify.

Yes, it covers work already done. I entirely agree with you that since work is super simple to conceal, having an explicit policy against rewarding complete work, especially in an open-source culture, would be silly. I certainly don’t want to hold useful developments for ransom.

I’d also agree that it’s a different kind of request! I won’t claim to know the best way for ZOMG to handle it, but I definitely think it’s cool to be having the conversation! :slight_smile:


Hey Michael / @BrunchTime!

Speaking on behalf of the @ZOMG, we agree that having a testnet faucet is important for onboarding devs to Zcash. We’re approving the grant proposal. Watch for an email about admin next steps :slight_smile:

Thanks for applying! We’re also going to tweet about this to help spread the message. Is there anything else we can do to find and send more people your way?

Could we also ask that you update this thread when you see good traction? Would be great to see how it’s doing.


Hey @ml_sudo / @ZcashGrants !

Thank you for choosing to fund this project! I’ll happily update the thread with some usage metrics in future. And I very much appreciate ya’ll tweeting about it! :slight_smile:


Hey ZOMG and ZEC friends! Here’s an update:

I found some time to jump into the code maintainability action over the weekend! I also added an acknowledgement for ZOMG to the faucet app (Thanks again!). Cleaned up the codebase, completed the project setup instructions, and even added a branch that works from zecwallet-cli instead of full node rpc. Repo Plus we’re rocking zcashd 4.4.0 now. :metal:

So far the faucet’s been tapped 47 times.

I hope you’re all having a wonderful April!


I also make a faucet of ZCash. Cause I love this coins​:smiling_face_with_three_hearts::smiling_face_with_three_hearts::smiling_face_with_three_hearts:
Here is my faucet 10bits.top
If you have any idea for my site , just be friends with me in there. Thanks

Its spelled ‘Zcash’ ™ and theres no terms of use link, also the 25 ads and trackers and stuff is a lot


@BrunchTime Faucet down?

It looks good to me. I just used it to send to that same address: https://explorer.testnet.z.cash/tx/efc00a137794ecb3b1948bd9cdc4c457ff756c16058a068e86710c1a4758405f

i reached out to kv for details :slight_smile: Thanks for the ping


Does it work with transparent addresses?
It returns no error but no txid and no coins either.

1 Like

Thanks for the q - It’s intended to - I’ll check it out

EDIT: Issue is resolved. Thanks again.

EDIT 2: I’d messed up fund management and run out of TAZ in the appropriate address :man_facepalming: The good news is that the faucet is getting used! It’s been tapped over 250 times now!


Thanks for your work on this!

Is the faucet down right now? I’m getting 502 from the OPTIONS request to api/sendtaz

1 Like

fwiw, it looks like the issue is that the page is sending the request to https://light-faucet.zecpages.com/api/sendtaz instead of https://faucet.zecpages.com/api/sendtaz

sending a curl request to the latter worked

1 Like

CC @BrunchTime with the issue

1 Like

kicked server, back in business. I can think of a couple pretty simple stability upgrades, will keep ya posted


the ZECpages testnet faucet (https://faucet.zecpages.com) seems down, i’ve tried both t- and z- addresses and none of the transactions get sent, running curl agains the sendtaz URL gives 502 Bad Gateway errors

1 Like

Can you please take a look at the faucet for items mention from @superbaud ?

1 Like

Thanx 4 the ping boss - fixed up.

sorry @superbaud and thanks <3

@BrunchTime Woot! Many Tys for quick response and patch! Much appreciated as always