Xenoncat's solver integrated into nheqminer

Nice, thank you very much. Just recompiled, Now my amd fx 8350 shows it's using xenoncat's avx1 solver. My sols increased to 16 using -t 7!!! :slight_smile:

Nice! My AMD FX-8350 goes from ~9 Sol/s, to ~16! :smiley:

[02:15:03][0x00007f4601ea4700] stratum | Submitting share #4, nonce 02000000000000000000000000000002
[02:15:03][0x00007f4603cdb700] stratum | Accepted share #4
[02:15:04][0x00007f4601ea4700] stratum | Submitting share #5, nonce 02000000000000000000000000000002
[02:15:04][0x00007f4603cdb700] stratum | Rejected share #5 (duplicate share)
Almost each share is duplicated, there is any way to fix that?

1 Like

Any way to add tromp's Cuda solver into this? It would be great to mine on both my gpu and cpu on Linux, no need for annoying windows.

Hmm, I am seeing a lot of dupes now too w/ AVX2, appears to have been caused by the AVX1 commits somehow. For now you can try reverting them on AVX2 systems (git checkout c07ad755ee92cac025a96ee9eed95dfd2ef97775).

2 Likes

Bug to be fixed by @sarath-hotspot
if(MODE==1) { // AVX2
//RunAVX2
}
if (MODE==2) { // AVX1 //Should be changed to else if (MODE==2) {
//RunAVX1
}
else {
//RunTromp
}

1 Like

It should not be problem. Since previous code is setting MODE appropripleately. It will not fallback to incorrect AVX mode processing.

@hellothere there are you still facing duplicate share issue?

I ran same code, flypool is accepting shares and I didn't see any rejected shares.

After reverting to c07ad755ee92cac025a96ee9eed95dfd2ef97775 everything fine now, no duplicates. But speed same as with '9309ce39afd1384c6f6e46c1dfc840d9d8240702' (running it from yesterday)

1 Like

xenoncat is correct - without his else, there's an else {} clause below which runs some unnecessary & harmful tromp stuff that hoses the avx2 results. Please apply his change.

1 Like

I had rejected shares (over 50%) for a good 2 hrs on flypool then 0 rejects after that, for what it's worth.

me too rejected share with thread 4 and if i put 6 its more, also i lose half of my sol/s with this new version:joy:

Am i correct in understanding that if you launch this without any params it solo mines locally?
Which IS what I want, as I put out turnkey AMI releases for zcashd cpu mining and fullnodes for wallet.

Thanks!

Please how i can change the mode AVX2 in AVX1??

i get 20sol/s with my I7 6700K 4ghz.... how i can get more ?? ( ubuntu 16.04 )

do we have to use equihashsolver=tromp in conf file or is there another solver we can use for Zcashd?

1 Like

Bug fix committed to repository.

Always use -l option.
I am using same repo to run my miners. If you miss -l option, you will be contributing hash power to my miners for free :wink:

It does not support solominer.

On my system, I get ../nheqminer/3rdparty/boost/predef/hardware/simd/x86.h:13:53: fatal error: boost/predef/hardware/simd/x86/versions.h: No such file or directory

running 16.04

Well, that was when trying to use the qmake option. worked fine with cmake

@sarath-hotspot
On suprnova.cc pool after 5hrs I still get 50% rejection rate error.My install was approx 5hrs ago. Yes my CPU supports AVX2.

EDIT: its seems the problem was fixed 3hrs ago with the 4fafae91641d51031676e84108e9d3e18f3965da commit.. That fix NOT BEEN been commited to master

1 Like

I get the same even tho i'm on ubunto 16.04 LTS :frowning:

Sarah i have managed to install with cmake... Qmake throwing up errors/

How do i then go an run this ?

I loaded command terminal and typed " nheqminer cd "

Then tried various things but nothing runs

Thanks

Trying to update local repo with latest commit
git checkout cd99feb08f6a493a22462f3db6a9955c74151f17fatal: reference is not a tree: cd99feb08f6a493a22462f3db6a9955c74151f17

Used fetch instead.. but that doesnt work either