Nvidia/CUDA GPU Hardware Questions

I am creating this thread for all of the specific NVIDIA Hardware GPU Questions, there have been a ton of "How much Sols/s can I get with my 1070?" Threads. So this will hopefully make information easier to find for all users.

Please consult this thread and feel for to add questions about Nvidia/CUDA. AMD has another thread.

which miner is good for old cuda cards?

which miner is good for old videocards like gt 730 and others ?

None since those aren't GPUs anymore.

GeForce GT 730
Speed up your PC multimedia experience. Upgrade to the new NVIDIAĀ® GeForceĀ® GT 730 dedicated graphics card and get super-fast web browsing, plus incredible photo and video editing.

This GPU is not meant to do anything other than to display your Desktop. Well, you can play Minecraft, I guess.
But it does not deliver any performance for cryptomining. :bread:

mmmmm ok thank you....

If the gt730 series of graphic cards don't help at all what would be a good low cost alternative for older systems. I plan to upgrade everything in the coming month but at this time I don't have that much cash but I want to mine for some zec plus the experience is helpful, please advise . I have a system running Ubuntu 16.0 , Pentium dual core 2.0 gh 64 bit processor 800MH bus Nvidia GeForce 7100/ 630i chips etc

gt 730 have cc3.5 i would try https://github.com/maztheman/nheqminer fork for it, but i would expect 5-10 sol/s only

Hi there folks.

I am running Ubuntu Linux with 6 GTX 1070s and am having some problems overclocking my GPUs. See below output:

owocki@owocki-desktop:~$         nvidia-smi -i ${i} -pl 170
Failed to set power management limit for GPU 0000:01:00.0: Insufficient Permissions
Terminating early due to previous errors.
owocki@owocki-desktop:~$
owocki@owocki-desktop:~$ sudo !!
sudo         nvidia-smi -i ${i} -pl 170
Power limit for GPU 0000:01:00.0 was set to 170.00 W from 170.00 W.
Warning: persistence mode is disabled on this device. This settings will go back to default as soon as driver unloads (e.g. last application like nvidia-smi or cuda application terminates). Run with [--help | -h] switch to get more information on how to enable persistence mode.
All done.
owocki@owocki-desktop:~$ nvidia-settings -a [gpu:0]/GPUGraphicsClockOffset[3]=200
ERROR: The attribute 'GPUGraphicsClockOffset' specified in assignment
       '[gpu:0]/GPUGraphicsClockOffset[3]=200' cannot be assigned (it is a read-only attribute).
owocki@owocki-desktop:~$ nvidia-settings -a [gpu:0]/GPUGraphicsClockOffset[0]=200
ERROR: The attribute 'GPUGraphicsClockOffset' specified in assignment
       '[gpu:0]/GPUGraphicsClockOffset[0]=200' cannot be assigned (it is a read-only attribute).
owocki@owocki-desktop:~$ nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[0]=1500
ERROR: The attribute 'GPUMemoryTransferRateOffset' specified in assignment
       '[gpu:0]/GPUMemoryTransferRateOffset[0]=1500' cannot be assigned (it is a read-only
       attribute).
owocki@owocki-desktop:~$ sudo nvidia-smi -ac 1911,4004
Setting applications clocks is not supported for GPU 0000:01:00.0.
Treating as warning and moving on.
Setting applications clocks is not supported for GPU 0000:02:00.0.
Treating as warning and moving on.
Setting applications clocks is not supported for GPU 0000:03:00.0.
Treating as warning and moving on.
Setting applications clocks is not supported for GPU 0000:04:00.0.
Treating as warning and moving on.
Setting applications clocks is not supported for GPU 0000:05:00.0.
Treating as warning and moving on.
Setting applications clocks is not supported for GPU 0000:06:00.0.
Treating as warning and moving on.
All done.

Here are the specs of my rig:

owocki@owocki-desktop:~$ nvidia-smi
Fri Nov 18 07:30:56 2016
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 367.57                 Driver Version: 367.57                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1070    Off  | 0000:01:00.0      On |                  N/A |
| 80%   48C    P2    95W / 170W |   1832MiB /  8106MiB |     95%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 1070    Off  | 0000:02:00.0     Off |                  N/A |
| 80%   46C    P2   118W / 170W |   1823MiB /  8113MiB |     82%      Default |
+-------------------------------+----------------------+----------------------+
|   2  GeForce GTX 1070    Off  | 0000:03:00.0     Off |                  N/A |
| 80%   48C    P2   121W / 170W |   1823MiB /  8113MiB |     85%      Default |
+-------------------------------+----------------------+----------------------+
|   3  GeForce GTX 1070    Off  | 0000:04:00.0     Off |                  N/A |
| 80%   46C    P2   114W / 170W |   1823MiB /  8113MiB |     79%      Default |
+-------------------------------+----------------------+----------------------+
|   4  GeForce GTX 1070    Off  | 0000:05:00.0     Off |                  N/A |
| 80%   49C    P2   109W / 170W |   1823MiB /  8113MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   5  GeForce GTX 1070    Off  | 0000:06:00.0     Off |                  N/A |
| 80%   47C    P2   104W / 170W |   1823MiB /  8113MiB |     82%      Default |
+-------------------------------+----------------------+----------------------+

Can anyone tell me what I might do to get my GPUGraphicsClockOffset and GPUMemoryTransferRateOffset to update?

Thanks,
@owocki

Tried the following, no luck so far:

nvidia-settings -a GPUCurrentClockFreqsString="nvclock=2040, nvclockmin=139, nvclockmax=2111, nvclockeditable=0, memclock=5302"

Figured this out. For anyone finding this via google, reposting from a reddit/r/nvidia thread where I got the answer.

You may need to update your driver, latest linux is 375.20, pascal overclocking was introduced in 370.x, and it seems you are using 367.57.

What's the best miner for CUDA on Linux available so far?

bump for exposure...

Another bump for additional exposure

another bump. so far i havent see one miner able to use CUDA on Linux :frowning:

bump, need something

Has anyone tried the miner mentioned in: https://forum.zcashcommunity.com/t/cuda-equihash-miner-with-devfee/6492

i wouldnt try that one, because the code is closed and you run a possible malware on your system. Also the 10% fee is not really a fee, but 10% of your processing power mines for the author (havent tried it tho, and am not sure if this is true - im referring to what the author said). Theoretically it could be possible to sniff the traffic and see what of the solutions is going where.. but im too lazy to try it.

The NiceHash people are currently trying to make CUDA run on LInux, i think it will take a couple of days until it is working properly.

they have released the cuda version on thier git hub i was using it last night on my gtx 970 getting about 21 sols/s

1 Like

I actually installed Nicehash nheqminer_cuda_tromp, and it seems working fine, although it consumes all my laptop resources, making it unusable for any other task