Z to Z transaction failure

Hi fellow zcashers,

recently I decided to test mobile zcash wallets and sent some funds from my desktop wallet to mobile.

The amount was 0.09 ZEC, it was a shielded transaction. Here’s TX id:
50f27b83b8af8c33561f7ea65d386b46b84c026a729fe83f8284ed2b2472debe

Here’s a screenshot from my ZEC Lite wallet: Screen Shot 2021-03-26 at 21.15.36.png

On zcash explorer it shows 952 confirmations, at the time of writing this, but in my mobile wallet there’s no incoming funds.
Here’s screenshot from my mobile ZEC wallet: IMG_0219.PNG

Did any of you experience such issues before?

I haven’t seen this issue, can you make sure the address you sent to is correct? And make sure the ZecWallet lite app is fully synced and updated?

It shows -734 confirmations
https://explorer.zecmate.com/tx/50f27b83b8af8c33561f7ea65d386b46b84c026a729fe83f8284ed2b2472debe

Numer of shown confirmations probably depends on the explorer. On zcha.in it shows 997 confirmations Transactions - Zchain

Last issue like this had to do with the system time being off I think but I’m really not sure

It is correct - here it is IMG_0220.PNG
I checked every single digit in it. Wallet is also 100% synced

Yeah looks like the one block explorer is wonky right now
Theres 0 inputs and 0 outputs and any rpc call I try with it throws any error it may be your wallet is corrupted somehow

There’s 0 transparent inputs and outputs. But there’s 1 shielded input and 2 shielded outputs.
My wallet can’t be corrupt, because I successfully used it for T transaction (you can see small balance on the screenshot IMG_0219.PNG), but my Z transactions are stuck by some reason

No they’re not stuck, in all likelihood they’re in your wallet but theres an error with displaying the correct balance

1 Like

Well I hope you’re right and they are in my wallet. Any ideas on how to get them displayed?:slight_smile:
That’s just 0.09 ZEC - I don’t care that much if I lost them but I do care that ZEC wallets function well, since I really like that project
P.S. It’ll be funny if in like 10 years from now someone reads this thread and those 0.09 ZEC will be worth a fortune

1 Like

Based on that other users thread, they just eventually re-appeared:

You might also try clearing the cache of the app, or restoring the wallet to a new ZecWallet lite installation using the seed phrase.

1 Like

Just restored the wallet on my other laptop from the seed (ZEC lite wallet is up to date, it was downloaded 2 hours ago). Still nothing. Hope I’m just missing something and it’ll appear some time after

Also tried to rescan the wallet - nothing has appeared so far

Can you try restoring the seed words in @NighthawkWallet and checking?

1 Like

Already tried that, also tried Unstoppable wallet - no result so far

My guess is you used an old (pre-Canopy upgrade) version of Zecwallet to send funds, but the mobile wallet receiving the funds was the new (post-Canopy upgrade) version of Zecwallet.

There’s a bug tracking this issue here: Use of old versions can result in "misplaced" funds · Issue #93 · adityapk00/zecwallet-lite · GitHub. The specific issue is the way an upgrade (ZIP-212) is handled, more details are in the bug.

The good news is that your funds are not lost. The link above has a workaround which you can try. I’ll also be releasing a new version of Zecwallet this week with a bug fix. You can update your Zecwallet and rescan, and you’ll be able to see (and spend) the funds after that.

3 Likes

Good to hear it! Then I’ll just wait and update my wallet as soon as you release the new version.
Thank you

2 Likes

Lol couldn’t verify that because I wasn’t single quoting the array, silly me! :stuck_out_tongue_winking_eye:

This is now released. Update your Zecwallet to v1.4.5, and rescan.

2 Likes

Everything works. Thank you!

1 Like