Zcash wallet commands

Hey every one!

Just got my zcash wallet up and running.
Do you have any usefull commands ? like to see amount of zcash?
Adresses to my wallet ?

Could use some tips, so I can get my payout directly to my wallet.

Regards ZyLoC

# Get balance of all z and t addrs
$ zcash-cli z_listreceivedaddresses
# Get z and t addrs from wallet
$ zcash-cli z_listaddresses
# Create new z addr
$ zcash-cli z_getnewaddress
# Show net hashrate/ps (Sol/s)
$ zcash-cli getnetworkhashps
# Get current block count
$ zcash-cli getblockcount

If you zcashd is active, run zcash-cli help for more options :slight_smile:

3 Likes

Good list of commands:

2 Likes

A payment was sent from a pool that I am using recently
though I can not yet see it in my wallet...
how do I know my zcash is set up properly and how long should I expect the transaction to take?
thanks

how recently?
as long as you sent the correct payout addr - verify that they didn't require a type t-addr for receiving instead of a type z-addr - and have zcashd idling, keep checking back balance with z_listreceivedbyaddress.

I created a t address and a z address but when I use:

$ zcash-cli z_listaddresses

only the z address shows in the list. Is the t address supposed to show too or is that a different cli?

2 Likes

me 2, how do i check my t address? and can we mine to a t addr or can we only mine to a z addr?

2 Likes

a good 1/2 an hour ago

im checking with ./src/zcash-cli z_listreceivedbyaddress "zcGz5ffXX67r8wfrScBEfBddFxUuahRwDuKS7CG...rest of wallet numbers"

yet nothing comes up

zcash is running

i think i updated properly, everything seemed to go smoothly
it is a z-addr generated by zcash

im using flypool with this command (not my address in this command below)

inwindows rig
nheqminer.exe -cd -l us1-zcash -u -u zcQzmkPKg7YxxB4bGYaccxmR8RJHi24tt7xYGJ1bb1CKefLj5XQTYSxcoiMWBdpChRmd5LVG8rXanWDKvGoaDE3mFpf7c4r.rig1

and in ubuntu
./nheqminer -l us1-zcash.flypool.org:3333 -u zcQzmkPKg7YxxB4bGYaccxmR8RJHi24tt7xYGJ1bb1CKefLj5XQTYSxcoiMWBdpChRmd5LVG8rXanWDKvGoaDE3mFpf7c4r.rig1

my conf file is

addnode=mainnet.z.cash
rpcuser=username
rpcpassword= with the generated pass here

and zcash looks like this:

Thank you for running a Zcash node!
You're helping to strengthen the network and contributing to a social good :slight_smile:

You are currently not mining.
To enable mining, add 'gen=1' to your zcash.conf and restart.

Since starting this node 26 minutes, 17 seconds ago:
- You have validated 909 transactions!

[Press Ctrl+C to exit] [Set 'showmetrics=0' to hide]

from flypool:

PayoutsPaid On From BlockTo BlockAmountTxSat
Oct 29 2016 08:04:19 GMT+0200 (CEST) 341 668 0.00331 ZEC

i think ill try switching to an exchange wallet and mine to exchange directly

nothing comes up being the following
[
]
right?

There's no -c flag for the nheq exe and username (-u) only has to be specified once.
maybe try checking status of your addr via flypools site?
whats the peerinfo and getnetworkinfo put?

yes correct just
[
]

the only site i see on flypool to check my transaction is this: https://explorer.testnet.z.cash/
which looks like its set up for testnet?

where else can i check it?

https://zcash.flypool.org/miners/[addr here]

Wallet commands are here: https://github.com/zcash/zcash/blob/master/doc/payment-api.md

Blockchain explorer is here: https://explorer.zcha.in/

1 Like

yeah i can see my miner info perfectly, thats how i got the payment info above
but still no payment received in my wallet :frowning:

It worked, it just took hours to get it
network seems very slow at processing trans

Thanks alot for the info! :smiley:

That link contains new zcash-cli commands, but zcash-cli contains all the bitcoin-cli commands also that can be found here https://en.bitcoin.it/wiki/Original_Bitcoin_client/API_calls_list

For example, to see your t-addrs you can do:
zcash-cli getaddressesbyaccount ""

(That link is convenient, but in fact doesn't contain all bitcoin-cli commands supported by zcash-cli as it's an older version of the bitcoin api than what zcash supports)

Can someone explain me how the transaction "fee" works? I wanted to send all coins from my taddr to a zaddr. However there is a 0.0001 transaction fee. After sending funds, a system created a new taddr that had 0.0001 balance. The remaining amount went to zaddr.

So i learned that transaction fee remains with the sender, however how do i send all the funds from my taddr and remove it? Or how do i tell it to send the fee to a specified zaddr?

I just started the zcash node 7 transactions validated. But how to I add a wallet address to the config file?

To add a wallet to the config file append the wallet option with location of your wallet to zcash.conf in .zcash directory which resides in home directory of your user:

$ echo 'wallet=/home/YOUR_USERNAME/WALLET_FILE' >> ~/.zcash/zcash.conf

For adding an address from another wallet to current wallet, you must dump priv key from that wallet

$ zcash-cli dumpprivkey YOUR_ZCASH_ADDR

and then import

$ zcash-cli importprivkey PRIV_KEY_FROM_ABOVE_ZCASH_ADDR