T-address shows zero but blockchain explorer shows zec received

Can somebody please help with this :

I cashout some zec from suprnova to my t-address.
Block explorer shows that there was 1 transaction. Some zec received. Nothing spent. But zcash-cli shows zero balance and no transactions (screenshots below).

Does it mean I have that zec or not ? And what should i do ? I’m so confused.

Thanks !

Can you copy and paste your address and the txid so folk can try it in an explorer?

Also what does z_gettotalbalance show? And z_getbalance ADDRESS ?

Thanks a lot for response !
I tried "z_getbalance ADDRESS" as you suggested and it shows the balance.

Also after that i tried "zcash-cli listreceivedbyaddress 0 true" and now that shows balance too.
Can it be the transaction just got through ? Blockexplorer was showing it already 20 hours ago with hundred of confirmations. Even though I see balance now I don't feel like I'm understanding how all this works. Or could it be that me using getbalance somehow trigger something that it started showing the balance ?

Thanks again !

is your local copy of the blockchain synced to 100% that not being the case is the usual cause of this

Could be. Is there some command to to sync it ?

It will try sync by default when you start up zcashd.

If you want to confirm that it's in the process of syncing run: zcash-cli getinfo and see what block height you're on. Wait a couple minutes and run it again to see if the block height is higher. If it's going up you just have to wait . As of this writing the current block height is 131416.

what platform are you on? lin/win/mac?