1060 Nvidia setup

Hi everyone
Am new to mining and i bought 1060 3 gb card but after setup it is giving me 20 sols which is not correct even gpu core clock is not going beyond 139 mhz and memory clock is 810 i tried google and every solution which i got from internet like installing windows 10 then windows update and windows 10 creators update updating nvidia drivers but nothing is working i am using windows 10 pro and nvidia 390.
Strange thing is when i plug my old gpu 1050ti in same system it is giving me 170 sols.
Yes i uninstalled graphics card using ddu after using with 1050 then again installed but didn’t worked
Not able to understand why this is happening anybody can help?

Power Supply (PSU):
Operating System (OS):
Riser Version:
Number of GPUs:
GPU List Model/Brand/Version:
Overclocked (Yes or No):
Overclock Settings:
mining software
Additional Information (Please include bat or config settings):

Power Supply (PSU): 800w+250w i am having two smps.
RAM: 4 gb ddr3
Operating System (OS): windows 10 pro
Riser Version: USB 3.0 PCI-E EXPRESS 1X16
Number of GPUs: two
GPU List Model/Brand/Version: zotac 1050ti oc and gigabyte 1060 3 gb
Overclocked (Yes or No): no
Overclock Settings:
mining software EWBF 0.3.4b

are you running something with EWBF? that doesn’t look like his config/bat loadout

No other application is running apart from EWBF and that config file is of EWBF only i am having doubt that 1060 is not getting enough power and based on input it is setting GPU clock to 139 to 189 mhz however memory clock is working fine currently with my 250w smps am giving power to mobo and all other components and for 1060 fan is powered from 800w and when i give power to 1060 gpu processor from 800w it doesnt start planning to change mobo input from 800w might be this should work lot of heck going mad

Solved issue root cause was 1060 was not getting enough power so what i did is changed entire connection of mobo with 800w SMPS and removed 250w SMPS now its working fine thanks @CitricAcid for the help.

Glad you figured it out!

(for others in the future) I was going to say some other options would be to swap the card locations and see if the problem follows the card or stays with the GPU0 location, that would indicate if it was a hardware problem in the riser cable or power supply cable etc

Thanks @wxxyz i did that as well but no help then i changed SMPS and found solution, just a general question can’t i add multiple SMPS now it’s working fine with 800W SMPS but if i will add more GPU again this will cause issue then how people are building 6 GPU-12 GPU rig??

What do you mean when you say SMPS? What does that stand for?

People are using a large PSU, like a 1600 Watt, or you can hook up 2 smaller ones, or one ATX style PSU and a server PSU for cheaper power: https://www.pyramidreviews.com/bitcoin-mining/best-power-supply-for-mining/