Asus Strix 1060 6GB serious issue

First off. Hopefully this thread will work since it relates to mining.

Just got my asus strix 1060 in the mail. I have installed it in my system. But I'm seeing less than 100 sol/s 80-95 to be exact.
As I swapped it out with my single fan EVGA 1060 6GB that saw 290sol/s

Cause Ino i should be seeing atleast 285.
Was wondering if anyone could help me out here. I tried overclocking it. but it only went to maybe 95.
Not really sure what the issue might be. If anyone can help me out. You would be my hero.
Or else ill have to go back to my single fan until I figure this out.

Linux is an option if none of this works. It might fix the issue.

Driver: 382.53
Mining Software Version: 0.3.4b (ZecMiner(EWBF))

Some things I haven't tried

Uninstalling/Reinstalling my graphics drivers and then re installing with the new card.
Checking to see if the Mobo & GPU PCIE slot thing is damaged.
Re-installing my OS
Testing mining on Linux
Did not use the drivers that came with the card.

If anyone has a solution that would be wonderful.

What I find strange is my single fan 1060 gave me 290sol/s. I did not even have the nvidia drivers installed and it was hashing that high. I than installed the nvidia drivers just for the hell of it and saw no hash change.

Installed my Asus Strix 1060 with the nvidia drivers that were already there....hashrate is below 95sol/s

Upload screenshot of MSI Afterburner.

Can do that later at home. Why Afterburner though may I ask. Probably to check the default stock clock ratings. They seemed low to me when I plugged in my card and check out the stats. But it might just be I'm not used to looking at that stuff.

You can try EWBF version 0.3.3b
It's better than 0.3.4b

Pic of MSI at stock settings.

Ha. Issue has been resolved. Opened Device Manager. Uninstalled my display driver. rebooted PC. and boom 295sol/s.

clock values and stuff still seem low.

Actually overclocked it a bit. Hitting above 300sol/s stable