2 x XFX RX480 8GB stuck at 300MHz -please help

Looking for some help here.. i (think) made the mistake of trying to adjust clock and mem using MSI afterburner on my XFX RX480 cards (also have an MSI Rx 480) and it appears both cards are stuck at 300MHz. I tried removing cards, removing all drivers, reinstalling. Even tried installing the cards on another computer with the same crimson drivers. BOTH cards error out in windows 7 and BSOD a few mins into bootup due to being set to 300MHZ. In MSI afterburner I tried to reset to default but GPU-Z confirm it didnt work. If I use either card as primary video for the PC at 300MHz the drivers keep crashing and i get a Blue Screen Of Death due to ati****.sys
Nothing works. I'm giving up at this point and need some help.

How can I recover these two cards? Same issue here but nothing worked for me... https://forum.ethereum.org/discussion/9499/rx480-stuck-at-300mhz

Settings > Disable ULPS in Afterburner (without Powerplay)

I even tried removing afterburner. On the computer that doesnt even have afterburner installed I can try installing and disabling.. These instructions? http://www.overclock.net/t/1587347/how-to-disable-ulps-cfx-windows-10-crimson

Thanks. will give it a shot

Yes, but if you do it that way you will need to redo it every time you reinstall or update drivers.

Plug a monitor in the hdmi port of card stuck. Should do the trick. If not change pci mode in bios to gen 1 or 2.

Turns out there is no ULPS setting in the registry. Tried plugging in HDMI to the impacted card (which is all of them :confused: ) and no go. Even after using the AMD drive removal utility and doing a complete reinstall. I think the card it just stuck at 300mhz and locks up the system. Trying to run any miner causes blue screen. Two computers, same issue. Although that leads me to believe the parameter that needs to be cleared is in the card itself.

I will try the PCI mode change and see what happens.. Any other suggestions or things I can try in parallel? Would flashing the stock BIOS back to the GPU help help to restore? All cards are stock bios. two of them were actually impacted becuase of setting i used in claymore itself. Nothing to do with afterburner. I tried running claymore with default settings and specfiyng the stock'ish settings but didnt help

Thanks!

Ok here are your steps:

1) REboot computer
2) Using Atiflash save bios of your gfx card
3) use DDU uninstallter to remove all traces of the current driver software.
4) Reinstall Afterburner or Crimson whichever you like
4) now check if the card is running at any other freq than 300Mhz
5) If yes, disable the card in device manager
6) Reboot the comp
7) Follow steps 3 and 4
8) Reenable the card and recheck the frequency
9) IF still stuck, reflash the card with your saved bios
10) Do not change any settings in wattman , wattool or afterburner during whole procedure (It needs to be stock)
11) Best luck

1 Like

Very long story short.. but this did end up working! Thanks @Maxmad !!
Had to repeat for each and every card individually, but it worked.. finally. Will never mess with mem/clock setting unless someone else has tested it, definitely not with afterburner. No clue why.

This rig is pulling about 235 H/s on claymore 4.0.
600 watts at the plug.
1 x Gigabyte RX 470 4gb
2x XFX RX 480 8GB
1 x MSI RX 480 4GB.

Hoping for more.. but not without all the headache. Stock i expected 70H/s across the board, but not seeing that. i=2 doesnt push much higher, but is now unstable for me due to cpu.80% pegged on an Athlon A6-5600K. With i=0 i get a about 25% cpu.
Anyway.. thanks!

1 Like

No problemo :slight_smile: Glad that I could help. Btw seems like your Crossfire setting is ON. YOu have 4 GPUs but only 3 temp settings. Turn that off too.
You can do the timings mod if you have reference GFX cards. I have got 6 MSI RX480 4G gaming x cards which dont really overclock much. (thanx to Hynix memory). I am currently running those at 28.2 MH on ETH and 67 H/s on ZEC.
Always save original rom.
Always reset settings before you flash new rom.
Always disable card in device manager before you flash a new rom
Cheers

Here is my tips Jar if you like
ZEC: t1PNUqfmF24N7P7miYiwbiseixKsiUW1zG1

2 Likes