Balance is zero after 20 mins of mining on testnet?


#1

I got zcash daemon running on a VM. Guest is Ubuntu host is Win7.

I added the gen command to the zcash.conf file. I start the daemon.

After leaving it for 20 mins i suspect its mining. When i check my balance I see 0.000000

What am I doing wrong?


#2

20 minutes is not a long time. Don't expect miracles, there are hundreds of people mining even on testnet.

Providing you're using RC2, make sure to enable Tromp's equihash solvers.

If you want to see evidence of it working sooner rather than later, use a miner which supports stratum, and mine against one of the pools - then you should be able to see evidence of shares submitting, even if you don't have a TAZ balance right away.


#3

You're probably not doing anything wrong, you probably just haven't won the reward for any blocks, too much hash power on the testnet right now


#4

Im mining with an I7 CPU unfortunately I do not have an AMD GPU.

I guess its pointless solo mining with this weak hardware. Should I look to mine in a pool if I am mining with just one cpu with 8 cores?


#5

How do I do this? Do I place a line in the conf file?


#6

What i7 model ?
With half an i7 4770k (VM), at 7sol/s, I got 5 blocks in the last 23 hours (most of them were during the first hours).


#7

Its a 3rd Generation i7. Im not sure the exact model.

Hey do you know how to enable Tromp's equihash solvers?


#8

Add equihashsolver=tromp to zcash.conf.


#9

No need to update using command? Just hit that line in .conf?


#10

no, just restart zcashd after you add it


#11

Mining for about 10 hours on testnet, AMD 8 Core (FX-8350), Intel 4 Core (Macbook Pro, top), not a single test coin. hehehe


#12

Wow i just hit that tromp solver in conf and managed to mine 8 coins in 10 mins... good work brother