BOUNTY HELP FOR 0.5 ZCASH: Getting 8x NVIDIA GTX 980 Ti GPU to be detected on Asus PRIME Z270-A Motherboard / Windows 10

Hello Community,

I am a newbie and have recently aquired 8x NVIDIA GTX 980 Ti cards. My end goal is to build a rig with the cards and mine crypto.

So I have done a fair amount of research into what I needed and from my understanding I have everything I need. This is what I currently have:

8X GPU (Nvidia gtx 980 ti)
1x CPU & stock fan (intel pentium g4560 3.5ghz)
2x PSU (EVGA 1600w gold & all cables)
1x Motherboard (Asus Prime Z270-A)
2x RAM (2x4GB DDR4)
1x SSD (128GB seagate)
1x Windows 10 OS on usb stick
1x M.2. to PCIE converter (ebay)
8x Risers (version 006 from ebay with usb and molar connections)
1x Open air mountain bracket (ebay)

The first step I took was assembling all the parts with the exception of adding any of the GPU's.

Windows 10 installed fine and updated. Along with the BIOS update for the motherboard from ASUS website.

When adding the first GPU I installed the driver from nvidia and it was working fine and even tested on nicehash seemed okay!

When adding the 2nd it does work but only in certain slots and then adding 3rd or anymore than that either the rig will not turn on and display just black screen.

I am also finding that windows comes up with all kinds of repairs when rebooting after adding more cards.

Troubleshooting wise I have already tried enabling the 4G Decoding option which seems to make no difference to the amount of GPU it can detect.

I will also add that the slots which work through 1 to 7 (PCIE) seem to be random and different ones work at different times.

I have seen lots of people online achieving 8 NVIDIA GPU's so I am sure it is possible with the equipment I have purchased.

The conclusion of my problem is that I simply cannot get more than 3 cards to show and its a struggle even getting it to that point.

Anyone willing to video skype call and assist with a solution resulting in all 8 gpu's working on this motherboard will be rewarded with 0.5 ZCASH for there time.

I can show you all my wiring and my setup on the video call and I have also ordered another new motherboard & all other new parts to be sure its not the parts which are not working.

Joey

This is now fixed, thank you. I am unsure how to close the post.

Hi Tigerminer,
could you pls let me know how to fix it? I'm facing the same issue on that Z270-A motherboard
Thanks

Update bios to latest,

F7 for advanced ->
System Agent Configuration -> DMI/OPI configuration -> DMI MAX Link speed - Change to Gen1
System Agent Configuration -> DMI/OPI configuration ->PEG Port Configuration - Change to Gen1 and PCIE Sprectrum clocking to DISABLED

next go to PCH Configuration -> PCI Express Configuration -> change PCI Speed to Gen1

Thunderbolt Configuration -> Disable (should be disabled)
Onboard Devices Cnofiguration -> HD Audio Controller -> Disabled

next press right to go to boot , and enable 4G

Should be all good.

good luck.

1 Like

Thank you for your instruction, I'm going to apply it right after when I get back home after work.
Just want to make it clear: do I need to change those configs first before plug in any GPUs?
Or I need to:
1. Keep all bios settings as default (including 4G disabled)
2. install windows first
3. plug one GPU in
4. install drivers
5. Make changes to bios as you mentioned
6. Plug all remaining GPUs and they are all recogined?

Thank you

I made all the changes, and then installed windows without any GPUs

then when all is done, i installed the chipset drivers, rebooted, let windows 10-15 minutes to find all its shit, then shutdown - insert risers and the GPUs and boot.

1 Like

FYI everyone - you don't need to set PCI settings to GEN 1 in bios. You can keep at auto and will see a little bit better hash vs. setting all 4 settings to GEN 1. This still runs each lane at x1 but @ 3.0 instead of 1.0 which results in slightly better hash rate per card.

1 Like

I had issues getting more then 4 GPUs with Gen set to auto. only when i set to Gen1 it reads it

Thanks to your help I managed to get 7 card recoginized in windows.
Just to note that windows must be installed in GTP partition as mentioned here:

but my 8th card which is plugged into the M.2 to PCI card was not recogized. If I insert it to a normal PCI slot using the same riser, it works
I also use the same Z270-A mobo

So, did you need to do any specific steps to get the 8th card work?

Thank you