Asus Prime-Z270-A cannot get more then 4 GPUs

So this is my final obstacle …

i got 4 cards connected with raisers on PCI-E slots 1,2,3,5 (if looking from the left) (gigabyte GTX 1080 TI)

the other 3 available slots do not get the card detected (not even as a question mark in device manager)

i swapped slots, i swapped raisers - all working fine, this is happening with different GPUs in different Raisers.

Slot 04 is never working. not even if one GPU is connected to it.

what i did so far: Enabled G4, set all to Gen1 (that solved other issues that i had and allowed 4 gpu’s), disabled all onboard USB except for one (need it for Wireless)

i`m getting really frustrated (enough to buy a different MB).

so anyone has a solution, or a suggestion on a 100% working MB that will allow 6 GPUs without tweaking and messing around with it - i will be very thankful :slight_smile:

I am using Prime Z270-As. I don’t have this issue. Most are running 7 cards right now. Some of your setting are different than I am using. I would suggest starting with this video:

Here is the one for the Z270-A. Use this as a guide

This guy’s videos rock. Take a look at his Ethereum HDD build out. He is also the reason why I now have an Orico SSD cloner. SO much faster to set up computers now.


i followed exactly what he said step by step, and it did not work for me, it only found 2 GPUs, after i lowered to Gen1 it found more and was stable.

can anyone recommend a better board ?

Yes I agree with grungriffin. I have multiple rigs with 7 GPU’s using this mobo. Its all in the BIOS settings and you do have some setting different than mine. However, I use Linux so its not exactly a direct comparison.

Also: when you are putting your rig together you can power up and down repeatedly. Some PSU’s hold charge even if you hit the power switch and unplug it. I leaned this lesson the hard way, If you don’t drain the PSU its the same as hot plugging a Pcie card… and well that does not work out well. Kill power, then power up mobo to drain PSU before you touch anything. The EVGA 1300 does this but not the 1600.

Thanks, i will try to change the settings again to those in the video.

and yes i am aware of the drain :slight_smile:

can you recommend another board that you are successfully installing 6 GPUs without too much bios changes ?

No that ASUS mobo is supposedly one of the best you can get now. If you use the M.2 port as a Pcie port you can get 8 GPU’s on that mobo. I had it working but it was too many watts (GTX 1080ti’s) for a 20 amp circuit so I’m staying with 7. I have some MSI gaming 5 mobo with AMD GPU’s but they were a Royal PIA to get working with 7 GPU’s.

6 GPU’s was easy though. Dont know if you can get that mobo anymore.

i somehow managed to get to a part where i connected 6 GPUs and saw 5 in windows but one was disabled… i dont know if its a windows issue or not anymore…

either way - is there a good guide for mining in Linux with NVidia (1080 if it matters) ?

Not really. Most info on the net is just bits and pieces and you have to find the right bit that works for you.

If you asked me to do something in Windows Id just give you a blank stare.

OH!!! One more thing, maybe this is it. Sometimes the card was there, but it wouldn’t reach out for the driver. I had to find it in device manager and request that it search for the drivers. This was usually for number 7 and 8 that I might have this problem, but maybe you are having it earlier.

So go to device manager => Other devices. Then see if there are any PCI devices. Right click to Properties. Then select update driver.

Hopefully this is it for you. If not, I believe that you may have a bad MoBo. Not the Asus’s fault overall, just maybe in your case.

Not the case sadly, there’s nothing in device manager… not even a bad or unknown device

I have a Asus Prime Z270-A as well and can’t get more than 4 GPU’s to work even with the settings in the video above. I can plug in 6x 1080 ti’s and see them all in linux, Windows 7 and Windows 10 but as soon as I try to run any miner the machine just reboots with no information as to why. Has anyone had a similar experience?

What is your PSU JokerToker? Sounds like it might be a power issue

EVGA SuperNOVA 850 G2 GOLD - 850 watt…I had 3 of these setup each running 2x GPU’s and then another 750 watt powering the mobo and the risers. I also tried to distribute the power for the riser across all 4 psu’s but it was the same situation where the pc just restarts as soon as the miner starts.

i restored mobo back to default, and set everything like in the youtube video again,

installed Ubuntu, same thing - i see only 4 GPUs.

and reinstalled back to Windows 10, and same only 4 gpu’s.

It turned out 2 of my 6 GPU’s were defective. I plugged them (1 at a time) into another machine with a 600 watt PSU and nothing else besides an ssd, mobo, cpu, memory, optical drive and as soon as I tried to put them under any kind of load like a game or stress test the machine just rebooted. Also, tried them on linux (PIMP), Windows 10 x64, Windows 7 x64.

Can anyone come in handy, as a result, I have such settings in BIOS:
BIOS => Advanced Mode(F7) - Advanced\System Agent (SA) Configuration\DMI/OPI Configuration - DMI Max Link Speed - Gen2
BIOS => Advanced Mode(F7) - Advanced\System Agent (SA) Configuration\PEG Porn Configuration - PCIEX16_1 Link Speed - Gen2
BIOS => Advanced Mode(F7) - Advanced\PCH Configuration\PCI Express Configuration - PCIe Speed - Gen2
BIOS => Advanced Mode(F7) - Advanced\Onboard Device Configuration - HD Audio Configuration - Disabled
BIOS => Advanced Mode(F7) - Advanced\Onboard Device Configuration - LED Lighting - Disabled
BIOS => Advanced Mode(F7) - Advanced\Onboard Device Configuration - Charging USB devices in Power State S5 - Disabled
BIOS => Advanced Mode(F7) - Advanced\Onboard Device Configuration\Serial Port Configuration - Serial Port 1 - Off
BIOS => Advanced Mode(F7) - Advanced\System Agent (SA) Configuration - Above 4G Decoding - Enable
BIOS => Advanced Mode(F7) - Advanced\RPM Configuration - Restore AC Power Loss - Power On

Your two defective GPUs, what brand and series are they? Did you buy them new, used, or factory refurbished ?

ASUS ROG STRIX GeForce GTX 1080 TI 11GB - ASUS sucks these days. I wouldn’t buy any of their products we recently did some custom builds with ASUS motherboards that had good ratings on Newegg and the same thing 3 of the 8 boards were DOA.

On a positive note the GPU’s that are operational run very cool even OC they run 50C or less in a room that’s about 75 degrees.

I have had great luck with everything that I have purchased so far from ASUS. Their STRIX cards that I am running are running about the coolest of any of my air cooled cards.

That sucks that the OP had 2 of them go bad. Let us know how their customer service is about replacing them please.

Hey! I have ASUS Prime Z270a mobo. I am mining 4 GTX 1080Ti and it’s super stable when cards are plugged in sequentially in the first 4 ports (counting from CPU side). I am considering buying more cards as this mobo suppose to handle up to 7. But I am noticing issues with the ports 5,6,7. If I re-plug any card from let’s say 4 to 5 or 6, the cards do show in the device manager, but I get freezes soon after I start mining.


  • BIOS is up to date
  • 4G disabled
  • HD Audio disabled
  • PCI ports set to use Gen2
  • Basically everything from the video above.


  • Anything obvious that I could be doing wrong? (remember 1st 4 slots mining works like a charm)
  • Maybe I have to have 4 slots used before I use 5,6,7?
  • Any ideas, what can I try?
1 Like