Cannot find a way to overclock Sapphire Radeon NITRO+ RX 580 8GB

I have follow this steps and cannot find a way to overclock the GPU. I have flash the GPU bios and I know they work because I tried it on a friend rig and they hash 30M/Hs. How ever when I connected to my rig is only giving me 27 M/Hs and I cannot find a way overclock and under volt. If I have my rig on for more then 30 min it shut down b/c I believe it consume more power then the PSU is capable on providing. Another issue is that when it's mining a temp status usually show up every once in a while but right now when I start Claymore's it does not show the temperature. I cannot find a way to determine at what temperature the card are running at. I tried installing trixx that it still does not show me the temperature of the card and cannot overclock which this program.

Hardware the I current have
EVGA Supernova 1300 G2
h81 pro btc r2.0
Sapphire Radeon NITRO+ RX 580 8GB GDDR5
SanDisk SSD PLUS 120GB Solid State
Kingston HyperX FURY 4GB
Intel Celeron G1840 Processor - BX80646G1840

When I connected everything I ran into a problem which was that I could not find a way to boot the OS using the GPU. The way that I solve this issue was by going into the bios and enable the on-board card as primary card. Then I was able to install the driver for the GPU's by using the embedded graphics card on the board. I have tried enabling external graphics cards as primary but I still get stuck in a black screen if I do that. I'm that sure if that causing this problem.
Can someone please help.

this was the tutorial I follow


and this is the setting that I have on the .bat file.

"EthDcrMiner64.exe -epool eu1.ethermine.org:4444 -ewal 0xe5225785023A3dc09cEb229d41D9BFDC563C3da2.worker1 -epsw x -dpool dcr.suprnova.cc:3252 -dwal juan123145.user1 -dpsw 123 -tstop 85 -tt 65 -fanmin 45 -fanmax 90 -cclock 1130 -mclock 2150 -cvddc 850 -mvddc 850"
on my friend's computer with the same setting he is able to get 30 M/HS per card and can overclock and a under-volt with out MSI afterburner or TRIXX

I am using the same images and my ETH rate is 28Mhs. The real problem is that I cannot undervolt the cards. Currently looking into a way to do that via BIOS, so I can run the system under Linux/EthOS. Any tips on how to achieve that appreciated!