Can't run zec miner


#1

First time I get message the msvrc120.dll is missing
then I have download the dll file put it in same file with miner and got this message


any solution please ?


#2

may be it’s Windows Defender or your antivirus
https://support.microsoft.com/en-us/help/4028485/windows-10-add-an-exclusion-to-windows-defender-antivirus


#3

missing DLL u have 2 options

  1. u download the missing DLL and paste it in miner directory and everywhere else where it belongs the paths can be found using google (if i correctly remember it shout be in windows/system32 or Windows/sysWOW64 )
  2. u give a tray and instal/reinstal direct x and the Visual studio packages from Microsoft web side

Edit: find a nice step by step manual here not shore if the download links are safe

http://www.dlldownloader.com/msvcr120-dll/#Other-Versions-of-the-Msvcr120dll-Library


#4

It’s highly unlikely he’d actually be missing any DLL’s. Possible, but unlikely.

I also wouldn’t recommend just downloading and pasting DLL’s off the Internet with little to no research. The most likely culprit is his AV software. He just needs to add an exclusion and possibly re-download the mining software.


#5

i know the dll s are always there even when missing dll error occurred at least when searching for them in the directories u will find them … iam not shore about the AV never digged deep to find the real reason just downloaded and coppy paste it to the program directory it worked every time for me


#6

While that does work, it’s not really the best way to fix the issue. Aside from the fact you have no idea what’s been done to the DLL you download off the Internet, it doesn’t resolve the underlying issue.

Obviously this a risk you choose to take when downloading DLL’s from an unknown source.


#7

the risk i take wen downloading anything from a not reliable source …nothing new :smiley:
i never had a problem after downloading dlls but tbh i experienced these errors with torrent games only 1 time with a miner and the 1 time it was mine fault didnt installed the VS libraries


#8

If the files are there, right click on them, go to properties.
in the properties window, at the bottom, look for an “Unblock” checkbox.


#9

still same problem , I have add it in exlusion of windows defender :confused:


#10

Fixed ,
Redownload Dll file ,
Reinstalle Nvidia Pilot from official app fro nvida website


#12

There are three possible solutions:

1.Disable Windows defender if you are using Windows 10.

2.You need C++ redistributable if you are using Windows 7.Download Visual C++ Redistributable for Visual Studio 2012 from the Official Microsoft website and Install.

3.Rare.Your files may be corrupt.Install again.