EWBF (CUDA) Miner Setup - Noob Help!

Hey guys, you’re expert advice is needed and very much appreciated!

I have been trying to setup the ZEC Miner provided through Nanopool Version0.3.4B and I can’t seem to get it to work. I have edited the start.bat file and included the ZEC address / minername Etc.

when I execute the start.bat file the command prompt loads, and the information is displayed for a few moments and then disappears. Also, the miner.exe file also disappears from the folder.

Can someone please help me setup the miner properly.

Also, I am running a Windows OS and Nvidia GPU.
Not on Linux or Ubuntu.

Please help!

Make sure your NVidia drivers are installed properly. If it can’t find a CUDA device it will close. Can’t tell you why a file is getting lost. That’s a bizarre thing.

1 Like

Not trying to be a jerk - but make sure you have Unzipped the ZIP file with the miner. You can click on them in Windows and see the contents as opposed to Unizpping them (I haven’t used Window in years and when I built a WIndows 10 rig last year I did this myself :confused: )

Beyond that, I have no idea why the .exe would disappear. That is a new one for me.

1 Like

Thanks guys, I updated my Nvidia drivers and unzipped the miner (obvi) lol. Still No Go
I’m getting a “System cannot execute the specified program” error in the prompt.

I believe it may be the file provided through the Nanopool link.

Can anyone recommend a clean file path download for a Window’s Nvidia Miner, and a good pool.

There are a lot out there, would be great to get your thoughts.

Thanks again!


Did you / have you set up the insertnamehere.bat file, if yes paste what you did here

did you place an exclusion in windows defender or what ever your antivirus /maleware software is for that folder?

1 Like

Yes, I think it could be the link. Firefox doesn’t like the zip, either, thinking there’s a virus in it or some such nonsense.

1 Like

If you have Microsoft AV then it will delete .exe and .com files without any notifications.
You must add exclusion for that folder that it´s safe after then exe and com files stay in folder.

Example for your bat file:

miner --server zec-eu1.nanopool.org --port 6666 --user ZCASH_WALLET_HERE.WORKER/YOUR.EMAIL@HERE.COM --pass x --eexit 3 --intensity 64 64 64 --pec

If you want to be able to adjust payouts etc then you need to add your email. That Nanopool address is for Europe change it where you kive and/or nearest you.

Location   Address                    Stratum Ports   SSL Ports
Europe     zec-eu1.nanopool.org       6666 or 16666   6633 or 16633
Europe     zec-eu2.nanopool.org       6666 or 16666   6633 or 16633
US East    zec-us-east1.nanopool.org  6666 or 16666   6633 or 16633
US West    zec-us-west1.nanopool.org  6666 or 16666   6633 or 16633
Asia       zec-asia1.nanopool.org     6666 or 16666   6633 or 16633
Japan      zec-jp1.nanopool.org       6666 or 16666   6633 or 16633
Australia  zec-au1.nanopool.org       6666 or 16666   6633 or 16633
1 Like

Thanks guys, turned out to be an exclusion issue. Fixed it

Up and running generating a solid sol count