Dead node v4.0.0 - reindex doesn't recover (FIXED)

So here’s what I’ve got :-

zcashd: main.cpp:2553: DisconnectResult DisconnectBlock(const CBlock&, CValidationState&, const CBlockIndex*, CCoinsViewCache&, const CChainParams&, bool): Assertion `pindex->nCachedBranchId’ failed.

This is zcashd v4.0.0 running on Debian, which has been going just fine until the power went out.

I’ve tried running with ‘reindex’, same result.
I copied blocks & chainstate from another node, same result.
Its dying at block 230018

EDIT: Node had txindex, experimentalfatures & insightexplorer enabled - turned that off & reindexing (DIDN’T WORK)

EDIT: Now building a new node from scratch & will import old wallet.dat

EDIT: I copied a fully working node, replaced wallet.dat & started it up with -reindex - SAME PROBLEM

EDIT: Restarted without ‘-reindex’, its still re-indexing but got past the problem block & is still going…

Any other ideas ?


Anything in db.log?

Also running under gdb with a backtrace could probably help.

1 Like

There was nothing obvious in debug.log

Its still reindexing (at blk 322500) so whatever the problem was may have cleared, which is also weird.

1 Like

It recovered & all back to normal.