Error in z8 upgrade

The Equihash params will likely change when the get the results from ARM & GPU testing back.
Have you tried adding gen=1 to the configuration file to see if it will connect to the blockchain?

Enabling miner does not solve problem. Even my VPS running Ubuntu 14.04 can't sync so I guess my laptop or network is not the problem.

I'm asking in slack....

1 Like

What is the current height of correct blockchain. My my laptop is still at 0 blocks but my VPS running Zcash is showing 517 which is probably not correct because z8 has been up since 3 days ago. Is the testnet forked to multiple chains?

I had read the parameters now are n=200, k=9.

Current block is 1709. In testing a computer with only 4GB, it had trouble getting the right block. Starting it with bootup may not have helped. Stopping and starting got it back on track. Mining my own chain and not seeing the correct chain crops up sometimes.

I think it always shows I'm not connected to leastauthority when I'm having problems.

So I guess the z8 testnet is forked.

Are you connected to leastauthority? It's forked only on our machines, i guess. I've got 2 of these right now.

I'm on the shorter chain, 527 blocks...

Definitely forked.

Do you guys see leastauthority established when you execute this?
lsof -i | grep zcashd

Your debug message two hours ago had the right number of blocks, 1686, and my version number

I keep forgetting that str4d has told me twice already. If yuo upgrade, a missing instruction is to delete testnet3 folder and files in .zcash (not zcash)

rm -rd for recursive directories

The z8 Equihash parameters are n=200, k=9. We don't know yet whether these will be the final parameters; they may be.

The way that solutions are encoded and the initial list generated will likely change in z9 for efficiency and bandwidth reasons, but that doesn't require a parameter change.

The reason for choosing both n and k to be higher for z8 was that this reduces solution run latency, while maintaining approximately the same (only slightly higher) memory usage. Previous releases had been constrained to choosing parameters such that n/(k+1) was a multiple of 8; that constraint no longer applies.

1 Like

Thanks, daira...

I did delete the old z7 testnet3 data before starting up z8. And I also tried deleting again the (short) z8 testnet3 data and syncing again. I still seem to be syncing to a short chain. I'm still on it -- the short chain,

I started 3 mining instances 2 days ago, then added 2 more machines yesterday. The two I added yesterday have the right block number and appear to be running good, but they are not getting any blocks. The machines added 2 days ago continue to add blocks. Block number is currently about 2027

Here's the difference in the log files upon startup between one that finds the blockchain and one that does not. I got the same results after re-installing. I guess the next step is to reinstall ubuntu.

connected and found block chain:

LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=1591,
size=3713338, heights=0...1587,
time=2011-02-02...2016-08-09)
Checking all blk files are present...
LoadBlockIndexDB: transaction index disabled
LoadBlockIndexDB: hashBestChain=688eabe9af5cd008321401cf7a545018e4712ed9d3cd90d6e7fb595385589743
height=814 date=2016-08-08 12:21:34 progress=1.000000
init message: Verifying blocks...
Verifying last 288 blocks at level 3
No coin database inconsistencies in last 289 blocks (289 transactions)
block index 1155ms
....
....
addcon thread start
msghand thread start
opencon thread start
ZcashMiner started
init message: Done loading
ZcashMiner started
....
keypool reserve 14
CreateNewBlock(): total size 1000

Here's one that can't connect:

LoadBlockIndexDB: last block file info: CBlockFileInfo(blocks=1,
size=2404, heights=0...0,
time=2011-02-02...2011-02-02)
Checking all blk files are present...
LoadBlockIndexDB: transaction index disabled
LoadBlockIndexDB: hashBestChain=51c2f288f9bb93d49ca55dd1dae38d4f4b9d52576d737dc04ae2f2234b753258
height=0 date=2011-02-02 23:16:42 progress=1.000000
init message: Verifying blocks...
block index 442ms
....
....
opencon thread start
ZcashMiner started
addcon thread start
msghand thread start
ZcashMiner started
init message: Done loading
ZcashMiner started
...
keypool return 2
Adding fixed seed nodes as DNS doesn't seem to be available.

Just adding my z8 experience - I was mining successfully with z7 on Debian. I upgraded to z8 and cannot make a connection. (getinfo shows no connection - same for getnetworkinfo). I then removed all zcash directories (zcash .zcash .zcash-params) and did a fresh install and compile following the Public Alpha Guide. Same results no connection is made. Just for grins I installed Ubuntu on another machine, repeated the zcash install steps with the same results. No connection is made.

I copied all of .zcash/testnet3 from another computer that was connecting, and now it is connecting. Yea. Will I be able to do that on the real thing without messing something up?

I did an install and during the first time I tried to mine it started, but also then on my command line (not under it) it gave an error code "cannot obtain a lock" on testnet3, "bitcoin core is probably already running". It only happened on the first run. I had seen it before and wonder if that's where the lack of getting a connection begins.

What makes alphatestnet.z.cash able to provide a connection to other computers participating on the testnet? Can anyone else offer their computer as a publicly available node for this purpose?

There is nothing special about alphatestnet.z.cash other than that the Alpha Guide recommends adding that node in your zcash.conf.

The problems with connecting to the testnet are caused by this issue: https://github.com/zcash/zcash/issues/1289 , which will be fixed by z9, due to be released today.

1 Like