Trouble compiling Zcash in Ubuntu

I’m brand new to mining– so new that I’m actually still in the process of setting up a way to mine. I am following these instructions ( and when it came to compiling, it seemed to fail (the code ended with Error 125 and said it was leaving the directory) and none of the tests have worked. Maybe I didn’t allocate enough RAM- it says the Memory I have on Ubuntu is 1.3 GiB and the disk space is 9.0 GB. I read that I needed 4.0 GB of RAM available to compile, and I don’t know how to add more to Ubuntu.

try this

@racheljessica When you first create your virtual machine you specify how much RAM the machine has to use. You can shut down the machine and go into the Virtual Box settings to change the amount to 4GB so Zcashd will compile correctly.

And you will need to give it much more disk space too, the Zcash block chain is currently about 13GB and growing so I would give the machine at least 50GB to start.