Error shilelding zec

Hello all,

I want to tell something happened yesterday: I tried to shield some zec, and have 2 bad experiences:

This is command I ran:
zcash-cli z_sendmany "MYTADDR" '[{"address": "MYZADDR" , "amount": MYAMOUNT}]'

1. In first attempt, my computer freezes when I hit enter. So I can’t get the operationid. When I rebooted, wallet seems to be exactly as before, without spent or moving from t to z address.

2. Then, I tried again and I have a “success” with z_getoperationresult command, and got an id. I ran getbalance and saw the “total minus MYAMOUNT” (amount I was shielnding wasn’t in my transparent balance).

2.1 But when I checked MYZADRR address, I realize it has 0 zec. So I think: “I will wait until all blockchain be synchronized”. And wait. After some hours I got 100% synch.

2.2 Then, I checked MYZADDRR again and still in 0. So I ran getbalance again and realized the original amount is there again. So nothing happened. When I ran z_gettotalbalance all is transparent.

2.3 Finally, I checked z_getoperationresult and z_getoperationstatus and nothing there.

What happened?
How can I shield my t zec?

Note: Zcash Daemon version v2.0.0

thanks in advance!
have a nice day!

1 Like

Issue 2 is to do with transaction expiry I think. As your node wasn’t fully synced you would have specified an expiry height that had already passed so the transaction wouldn’t have been mined, hence it appeared back in your wallet. There are a few issues
about this like https://github.com/zcash/zcash/issues/3393 (I need to look it up but I think you might be able to pass the expiry height now too?), but long story short try sending again once you have a fully synced blockchain.

Edited: you can pass expiry height to createrawtransaction RPC method but not z_sendmany see https://github.com/zcash/zcash/issues/3333

What OS are you running the client on?

And can you confirm you’re on the mainnet?

Hello,

@garethtdavies thanks ! I repeated the procedura again with fully synced blockchain and works perfect

@paige it runs on linux (kernel 4.8.x) and yes, on mainnet.z.cash

thanks and wait here for doing more debug if needed

2 Likes