EWBF Miner / 1 out of 6 1070 Ti's only hashing / Mining Thread Exited With Code: 2

So I have finally managed to get this rig recognizing all 6 cards in device manager, although in EWBF Miner, I can only get 1/6 cards hashing. If I disable the other 4 in EWBF, I can get 2/6 cards working. I seem to be getting the same error over and over again. “Mining Thread Exited With Code: 2”.


  • All GPU’s, Risers, PCIE slots are working, as I have individually connected them separately and they can hash fine. Everything works fine up to 2 GPU cards before I start getting that error on the 3rd when connected with any variation.

-Have the latest motherboard chipset, BIOS drivers(F8a).

-GPU’s are currently running at default settings. Happens on 60% power limit as well.

-Have tried adjusting Virtual memory value as I kept getting no resources, although no fix.


6x 1070ti Zotec Mini
Gigabyte Z270P-D3 Motherboard
Crucial 4GB Memory
EVGA 1200w
Windows 10 64bit running on 32GB USB Thumb Drive

Any help is appreciated, as this is frustrating as hell.


1 Like

So, you put all 6 gpu’s in then tried to get it to mine AND expected it to work? no no no no no… why would you do that?

  1. install gpu, once recognized in device manager with correct driver, move to step 2
  2. Run mining software, everything works for 30 to 60 seconds - if yes, then shut down install next gpu, if no troubleshoot.
  3. repeat step 1

ALso you didn’t list PSU wattage

1 Like

Does Device Manager in Windows show all the devices?

Are these all running off the same PSU?

What risers are you using? How are they powered?

Have you enabled 4G decoding in the BIOS?

1 Like

I actually did do that, and mentioned it under notes.

I originally connected 1 gpu then got it working, went onto the 2nd gpu which worked, and the 3rd gpu would always get that error code 2, with any variation of the 6x gpu cards I connected. I figured through process of elimination that error is not coming up due to the cards/risers/pcie slots and due to something software related.

Whoops, PSU is an EVGA 1200w.

1 Like

Yes, all 6 cards are recognised.

Running off the same PSU. EVGA 1200w.

6 Pin Risers. I am powering them straight from the PSU. Single PSU 8Pin to a dual 6+2 Pin, which connects to 8pin on GPU and 6 pin on Riser.

Yes 4G is enabled. I followed the Gigabyte mining instructions.

1 Like

I thought I might test out NiceHash Miner to see if it threw any errors and I was correct.

Keeps coming up with “Out of Memory” Errors whilst I do the Benchmark option.

NOTES: Virtual Memory is set at 14000

1 Like

Set the following environment variables


For multi-GPU systems, set Virtual Memory size in Windows at least 16 GB:
“Computer Properties / Advanced System Settings / Performance / Advanced / Virtual Memory”.

1 Like

Yeah its an issue with running windows from the flash drive. You need 16GB of virtual memory at least.
Use a bigger thumbdrive, get a SSD or HDD and it should work fine.
Do what @CitricAcid said in regards to virtual memory or google it.

1 Like

Quick update. I switched the USB Thumb Drive for a HDD and everything works a treat!

Thanks again for the help, much appreciated!

1 Like

Just out of curiosity, what do those environmental variables do?

Yeah I always thought that rule applied only to 8+ cards, guess not.

Thanks for the help!

1 Like

Out of all the builds I have watched, I have not seen anyone really talk about virtual memory so it kind of caught me out.


1 Like

Those instructions are for other miners, not EWBF. They’re only applicable if you are using AMD cards,

1 Like

Ahhk got it. Thanks!

1 Like

and yet it resolves so many problems with EWBF, DSTM and etc

1 Like