EWFB miner strange new Error: Cannot load nvml

I hear the mods are extremely responsive here <3 Sorry for the copy/paste, as this is originally posted by me on reddit:

I successfully built a new PC a few days ago, and started to mine with it to great success. The 1060 effectively tripled my mining speed, as before my laptop’s 970 was chugging away. Everything was going well until it wasn’t. Been mining zcash with EWBF’s miner.

fypool.bat no longer runs, it brings up the cmd for half a second and then crashes. The file itself looks good as far as I can tell. Nothing was corrupted. I have all the dlls I need.

Things that happened before it stopped working: - played Skyrim on highest graphics - power went out for an hour - installed some programs

I have been browsing for hours with no success as I see this seems to be a very rare error. Here’s an image of what I see attached: https://imgur.com/gPLjUUD I only get to this point when I shift right click, open powershell. CMD crashes like I said. Most forums are of no help so I’m asking you detectives if you have any idea what’s happening.

can you copy and paste the config/bat file please?
What O/S?
Are you using a riser?

Bat file I have been using: miner.exe --server us1-zcash.flypool.org --user t1L9WBHd2Et1XB5Nrdi6DPBGie5FUuchh4s.Lump --pass z --port 3333
EDIT: the config file does show other servers, some connecting to nanopool or dwarfpool, but these would only run if the provided one fails, and still doesn’t explain the crash. Temp limit is set in the config file to 80, but I never see it go above 65 with afterburner.

Windows 10 Pro for the OS.

Nope it’s plugged directly into the PCI slot (though I did find the thread which suggested that could be the problem!).

In the mean time I have switched to Excavator which works fine but it’s slower by about 50 Sol/s so I would really love to get back EWFB.

I have two suggestions to resolve this for you, both should be done, but I think the second would will ultimately fix it.

  1. download and do a fresh install of EWBF ( you can copy the bat file over, but nothing else).

if this doesn’t resolve it

  1. download DDU and run it in safe mode. completely remove the Nvidia drivers. Reboot and do a fresh install of the Nvidia drivers (latest version).

NVML is a library file in the drivers from Nvidia. This file is either missing or corrupted.

It is important to run DDU to do a complete removal.

You’re a god. Reinstalling graphics drivers after using DDU to remove the old ones solved the problem. I wonder how the library file so quickly got corrupted/deleted but anyway… everything works now, thank you!

fantastic man fantastic