Full node regtest mode unable to connect to the nodes need help

Hello, it’s my first time using the forums.

I recently tried to setup zcash full node on macbook m1 with Ubuntu(on UTM).
And I finally solved the problem of unable to install gcc+± multilib through normal commands on arm64, and followed the steps to install zcash(though source code)

But when I finally run it in regtest mode, I can generate blocks but I can’t connect to the nodes after addnode command, I checked getconnectnode and getaddednodeinfo, they all show that I added the nodes but they’re not connected to my local computer. I want to run a private network with some nodes and blocks to do some experiments.

I checked these:

I checked both firewalls on ubuntu and macbook, they’re both not active
Screen Shot 2023-10-13 at 3.05.29 PM

My config

(I asked chatgpt to generate some addresses for local address nodes)

The result of getaddednodeinfo

The result of getinfo
Screen Shot 2023-10-13 at 3.08.27 PM

Error log looks like this

Also I switched the vm network type to bridged but still don’t work(and for some reason can’t access the wifi if I use the browser), current network type is shared network.

Not sure what’s the problem here is.
I really appreciate it if anyone can give me some help, thanks~

1 Like

Sounds like you need to enable connection options. Check the zcashd doc manual for all that

1 Like