Gtx 1070 rig. 1 gpu has lower sols than others


I started 2 days ago with mining.

I have a Biostar TB250-BTC board
V1200 platinum Coolermaster PSU
4gb DDR4 ram
6x Asus GTX 1070 Dual 8gb
Running on windows 8.1
Cuda_8.0.61_windows as driver

On Afterburner I have the following settings:
Temp limit 85
Core +190
Mem +630
Fan speed manual at 75

All my GPU’s are working at 445-470sols/s except for GPU3. When I start up, he runs the same speed as the others for a couple of minutes and then drop down to 360-380 sols/s.
I’ve tried to read up on threads about it but they are not very informative.
Can anyone help me resolve this?

Thank you

I have four 1070 rigs, mostly EVGA, a few with MSI and/or Gigabyte and Zotac. When I open Teamviewer and start working from the rig desktop, the card that’s being used to provide the display always drops like this. Once I close out Teamviewer it goes back to full speed. I have to assume the hashrate drops to allow the card to provide the display. This happens with a monitor hooked up or when no monitor is attached and I’m only viewing the desktop through Teamviewer. Hope that helps explain your situation.

Funny enough, its not the card im using for display.
I have even tried switching the usb cable of the risers between gpu2 and 3(to let gpu3 be nr 2 on the pci slot and 2 be nr 3) but its still at lot GPU3 which gives the lower sol rate(thus a different card). I havent switched the power yet, that’s my next try

Hi, i’m going trough the same problem, did you find a solution for this?

Another thread the user checked his bios, it was an older version. check it bro.