Low performance in the gpu that shows the desktop?!

Hello everyone,

Let me see if you can help me with a problem that is coming up right now.

Everything was perfect until I expanded to 6 gpus. I bought a new motherboard (asrock h110 pro btc +) to gather all the graphics I had and now I find the following problem.

It turns out that the gpu used to display the desktop, affected its productivity. The “Sol/s” drop a lot with respect to the others. In the specific case of the image, it can be seen that the second (it is an Nvidia 1070) is at 170 Sol/s while the fifth (another Nvidia 1070) is at 431 Sol/s. Both with the same configuration, being the only difference between them that the first is the one that has plugged the monitor.

So far, the normal thing is that the gpu that carried the whole graphic environment lowered its productivity about 10-20 Sol/s, but not 300 Sol/s.

I’ve also tried putting a 1080 on the desktop and it works exactly the same.

As seen in the image too, the current performance is at 44%. It seems like the EWBF does not put it to work like the rest.

Please, does anyone think it can be? or what can I try? because as much as I look I can not find anything about it.


Ok, not an expert on this, but just some ideas on the top of my head:

  1. Do you have enough power on the PSU? You’re close to 1kW on the gpus combined, and the system also requires some power. If the cards don’t get enough power, they can’t work.

  2. Don’t know if I read you correctly, but did you put the monitor output on a different gpu to test? Have you tried to use the iGPU to display the screen?

  3. Is the 1070 in question in any way connected to the 16x e-pci slot on the motherboard? Hav you tried to put it on a riser on one of the 1x slots?

  4. Is it possible that your overclock/power settings are set way low for this card? Did you double check your settings?

isnt the 1070 crashed ? and mining on minimal settings? check the frequency of the card in gpu-z please (afterburner sometimes reports the setup frequency even after gpu crashed and frequency is default )

In the past few months running 3 separate rigs, all with 7x 1070s, this does happen. Not always, but always on the card plugged into the monitor. Also happens when using Teamviewer and nothing is plugged into monitor. Card normally goes back to normal almost immediately after logging off Teamviewer or turning off the monitor.

Plenty of power from PSU, regardless of OC settings.

Going with 6 or less cards instead of 7 it almost never happens.

Only advice I can give it don’t keep the monitor on.

Thank you before anything.

I continue to give more details of how everything is working. Clarify that it is mounted on an Ubuntu (Linux). And all the gpus are connected by risers.

1.- I have two psu right now. Both Corsair Plus Gold. One of 850w (2x1080 = 400W + 1x1070 = 170W + Motherboard ~ = 700W actual consumption) and a 750w (2x1080 = 400W + 1x1070=150W ~= 500W). 1080s are limited to 200W without overclock and 1070s to 150W and 170W without any overclock too.

2.- I tried with several gpus. With two 1080s and with the current 1070 and with all happens exactly the same … Low Hashrate on GPU 0. What I have to try is to try to use iGPU, I will try as soon as I can.

3.- Always connected by riser.I have tried with two different riser too and nothing.

4.- None of the connected gpus is being overclocked right now. For example the only difference between the two 1070s right now is the power limit. The one with a low hashrate is up the power at 170W.

I’ve tried it with two 1080s and it works exactly the same. For example, since that 1070 is not the GPU0, it works perfectly at its normal hashrate.

I currently run 6 GPUs. I’ll try to let 5 see if the same thing is still happening.

Also comment that when booting without a monitor, the same thing happens (lower hashrate)

That GPU that is the GPU 0 always has a much lower hashrate.

Head over to Amazon and get some HDMI display emulators for each display adapter in the rig, including the built in graphics one. Switch the motherboard to prefer the built in graphics card over the others, then boot. Not sure how you would configure SimpleMining but on Linux you can then set the internal gpu to be the primary display. Then your mining programs all work off the internal gpu and stay away from the mining gpu’s. That should restore your sol/s on the one card.