HELP! UTXO Error when sending zec

I received ZEC to my t address. I try to send this and says error: no UTXOs available to spend. I see it in my t address wallet the balance of my zec received.

I want to send to my poloniex account and enter the command like this:
./src/zcash-cli z_sendmany "$TADDR" "[{\"address\": \"my poloniex t address\", \"amount\": 0.50}]"

opid-e123134iyui233453409fdoid (blah, blah, blah)

Status of OPID is failure:
./src/zcash-cli z_getroperationstatus

I GET THIS ERROR THAT"S DRIVING ME NUTS:

"message" : "could not find any non-coinbase UTXOs to spend."

PLEASE HELP!!!!

Amount and address vars are round the wrong way.
See 'Sending coins with your z-addr' https://github.com/zcash/zcash/wiki/1.0-User-Guide, for correct method

Thanks,
I received the zec from genesis mining who sent it to my t address. So, it doesn't need to be shielded to my z address. I should be able to send form my t address to my zcash miner t address at poloniex.
No? I thought only mined zec needs to be shielded into z address prior to sending.
BTW, i tried to send some zec from my t address to my own z address....failed. doesn't work.

That's not true, the curly brackets represent a group of key-value pairs. Order shouldn't matter.

I'm trying to send from my t address to another t address.
The ZEC I have was received by my t address from Genesis mining.
Does ZEC need to be first sent from my t address to my z address first?

Get Outlook for iOS

Haejin I'm having the exact same problem starting today. Same issue, pool mining and trying to send to POLONIEX.

I was able to send without problem yesterday, same exact send command.

Did you get anywhere with this problem?

I am having the same issue: I get
error:-26
message: dust
when checking the operation status
Any ideas yet?

II tried installing the new 1.0.1 wallet - almost lost all my zec in the process, make sure you backup your zcash and .zcash folders before you update!!!! Not sure if it updated correctly

Rebooted the instance, no luck.

@disadapted are you trying to send ZEC to POLONIEX or another pool? Wondering of this message might be coming from the pool?

This is frustrating I wanted to average into this zec crash at least.. Not really sure what to do, I wish one of the ZCash guys would hop in and help us!

@Haejin and @disadapted -- I solved both of your problems

If you do a ./src/zcash-cli listunspent you see your unspent transactions

Next to address - that's probably a different T-ADDR than you were sending from, Try that TADDR as your FROM address - bet it works like a charm.

The the 64:Dust message -- It means that whatever you're sending, the leftover amount is too small for the wallet to mess with (it's "dust". I fixed by just sending .001 less and leaving some ZEC in the wallet so it wasn't too small.

Hope this helps, please let me know if it worked for you. Cheers!

1 Like

Thanx Slippinjimmy, That was the issue ... "dust"

1 Like

ofc, what an earth was i smoking

2 Likes

No, you can send straight from t to t.

Thanks @SlippinJimmy, had the same issue with dust and you explained what that error means. Sending .001 less helped me

1 Like

ZEC: Received error: {"id":4,"error":{"code":-32700,"message":"Cannotfindjob"}}

can anyone help ..
i don't get what this error is