How can get ycash on fork in exchange

hi, I have zcash on one exchange, and no wallet outside it. how can I get ycash on frok?please explain simple. I’m not expert. thx

Move funds to a wallet where you hold the private keys
You need the private keys to claim


thank you for answer, then I should move from exchange to a wallet? true? and is it nesessory to maintain zcash in wallet in fork time? or I can move back zcash to exchange before fork and just have wallet private key?
and one more questin? all wallets that support zcash and has private key is ok? or any special wallets support fork?

Im pretty sure I know the answer BUT I dont want to tell you the wrong thing
@hloo is the man to ask, he’s launching the fork and checks this forum pretty frequently
The Ycash discord link from their twitter where you can reach him as well


thanks but I think link that you privided is private, I cannot see it

@iliak, in order to guarantee access to your YEC, you need to have access to the corresponding ZEC private keys, so that you can import them into YecWallet.

The important point in time here is block height 570,000. To answer your question, yes, at block height 570,000, it’s necessary for the ZEC to be associated with private keys that you control. So if you transfer it to an exchange before that, the exchange, not you, will get the YEC.

There are various types of wallets, and not all of them make it easy for you to export your private keys. ZecWallet is the recommended wallet, but that will require you to run a full node. For other wallets, you’ll need to confirm that you can export your private keys. For example, I believe that Jaxx Liberty allows you to export your private keys, but you should confirm for yourself by experimenting with that wallet or asking its developers.

The only exchange that has pledged to support the fork and credit you with YEC is Safe.Trade. But you will have to decide for yourself whether you want to trust any exchange with your ZEC at the time of the fork.


thank you alot for complete answer.
I understand that.
one more question
when I should import private key to YecWallet? any time after fork is ok? or it has time boundry?
I’m sorry for my basic questions in advance

Any time after the fork is okay. There is no time limit. Even several years after the fork is fine.


really thanks alot :slight_smile:

1 Like

Hi, I read your suggestion because I was wondering the same thing but I think I have a problem…
I tried to send my Zec from one exchange to my Zec-Wallet on my Mac (I have downloaded it for the first time right now).
The exchange wasn’t accepting the z-Addr so I created a t-Addr and it worked.
So I sent my Zec while it was still sycing (the balance is not updated but I didn’t think it was a problem).
I clicked on Balance just to check it out then I clicked again on Receive and while the z-Addr is still present, the t-Addr vanished!
What’s gonna happen now?
Will I receive my Zec from the exchange? :frowning:
Please help me… it’s syncing and it’s still at 16.3% and I’m afraid about my money :frowning:
Do I have to click on New Address again? And what happens if it changes?
Thanks in advance…

1 Like

I don’t know how the mac version works. but if the exchange sent to a t address, then it will show up when it is synced.

You ‘might’ need to do a rescan once you have the whole chain, but for the moment, relax. I cant see any reason you will lose your funds.

Grab a cut n paste of the t address. just incase you have to manually re add it, but I doubt it. Also check on it should show up as mined and as balance.

1 Like

Thanks mate, I asked in a Telegram group too and they told me it’s about privacy and it’s normal… Every time you need to do a transaction a new address is generated so it’s apparently normal you don’t see it anymore… It’s 20% now in syncing… I hope everything is gonna be fine :stuck_out_tongue:
Thanks again : )

1 Like

It sounds like you are either aussie or from the uk like me.

Im off to bed in a bit. but if you have trouble tomorrow feel free to PM me or post in this thread. and yeah it does create a new address each time. doesn’t mean you cant reuse addresses, it is just discouraging it.

Good luck mate.

Oh and welcome to the forums :slight_smile:

1 Like

No I’m Italian but I watch a lot of tv shows LOL
Thanks again : )

Hi, the sync finished but I don’t see anything. I made 4 rescan and nothing happened.
There is no trace of anything anywhere, not even on the blockchain explorer…
Now I suppose I can only contact the exchange… am I right?
BTW I just opened another thread about this problem :frowning:

If you can’t see the balance in the blockchain explorer, then the funds have probably not been sent. You need to contact the exchange.

1 Like