How to find out my wallet address?


#1

Ladies and gentlemen,

I've set up a mining node under Ubuntu and have been mining coins for a few hours

Help me please! I want to check my balance on blockchain explorer, but I can't find my wallet address where my coins are.

Transactions point to different addresses

~/zcash/./src/zcash-cli listtransactions
[
{
"account" : "",
"address" : "n49QtsmPNKknerta7yV5GtNdymeZcfo2Kx",
"category" : "generate",
"amount" : 1.60400000,
"vout" : 0,
"confirmations" : 450,
"generated" : true,
"blockhash" : "003bd4574b4b7314e5f15901cc2a74b60ad1e830fd9dd05f459bd4a1837a2822",
"blockindex" : 0,
"blocktime" : 1472633106,
"txid" : "a9812dc95d6aef4b166a19943c9de0d9e3ad6af1b21df6629034dd32eb0b398f",
"walletconflicts" : [
],
"time" : 1472633106,
"timereceived" : 1472633137
},
{
"account" : "",
"address" : "mxswJMCmAdRHv2Snnto7aZsU1xqyUkZDce",
"category" : "immature",
"amount" : 1.82450000,
"vout" : 0,
"confirmations" : 46,
"generated" : true,
"blockhash" : "001fe84fd239390f65179abce22d09f636a27837fd9c45ea20932702d0102aa9",
"blockindex" : 0,
"blocktime" : 1472695897,
"txid" : "fb0460839a03bc01572c93658089e9d17aa4dd5fdeedfa0ff0a5ec81877875d0",
"walletconflicts" : [
],
"time" : 1472695897,
"timereceived" : 1472695943
}
]


#2

zcashd selects a different address from your wallet for each coinbase address in the blocks it generates.

btw This block explorer isn't showing a balance for your transactions...

https://explorer.z.cash/address/n49QtsmPNKknerta7yV5GtNdymeZcfo2Kx


Setting payment address using zcashd for mining
#3

Each generated reward goes to a new address by default..

@Voluntary I'm not sure why the address isn't showing.. The block explorer shows that address in the blocks:

https://explorer.z.cash/block/003bd4574b4b7314e5f15901cc2a74b60ad1e830fd9dd05f459bd4a1837a2822


#4

I may have spoken too soon on that... I tried those addresses (and one of my own) in the explorer from a Tor connection - I guess it doesn't like that.

Edit: Searching the transaction id from a Tor connection worked.


#5

There's a bug somewhere in the patched zcash build used by the explorer. It wasn't there a few days before the explorer was launched, so it hopefully won't take too long to isolate...


#6

How is it possible to see all addresses?

It must be a command or something