I am up and running, but I have several questions now and would be grateful for your help

Hi

I can tun the inbuilt miner no problem. Please note, I am yet to pull down the full block chain, that may resolve issue 1.

I would like to use my GPU, this is where I need help

Here are my questions:

On the 1.0 user guide there is a heading called “Generating a t-addr”

When I run this command (inside or outside of my zcash folder), nothing happens
./src/zcash-cli getnewaddress

Same when I try the next heading - a z-addr.
./src/zcash-cli z_getnewaddress

Like I said, I am yet to synch the block chain, so this could be why.

  1. I am following this guide on mining software

I have previously used Claymore, but is it only for windows?

  1. I am a bit of a noob at building, how to I build this miner?

I would love to know this for general skill improvement. I DLd all the files and extracted but I am not sure where to put them / how to install them

under “Recommended Drivers”, in the link just above, it says these are the best drivers:
fgrlx 15.30.3 for all GCN 1st-3rd gen cards
amdgpu-pro 16.40.5 for GCN 4th gen cards (RX4*0)

How do I tell which Gen my card is? It is a 7970 - I think that is equal to a 280x. I think it is 3rd gen, and I have installed the fgrlx 15.30.3.

  1. I have installed my sensor software, but is there any gui option like MSI afterburner? Just checking, all good if not:slight_smile:

Thanks guys

Item 1 is solved, I just had to run the software and issues commands in a new terminal

Hi

I got 3 sorted out, but I have a new issue trying to extract the AMDGPU-PRO Driver

Following instructions

http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx

I run (sorry not sure how to wrap code here, should I use snippet?

tar -Jxvf amdgpu-pro-17.30-492261.tar.xz

And out put is

tar (child): amdgpu-pro-17.30-492261.tar.xz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

I went back to windows install and managed to get the zcash for win wallet going, just having issue with claymore now.

When I start the miner it says
unknown option GPU_FORCE_64BIT_PTR 1
unknown option 1
unknown option GPU_MAX_HEAP_SIZE

etc

But then it starts. Any help?