My cards are not working together when mining. Help!

Hello, so recently I started zCash mining. I have a bunch of older GPU's so I thought I would give it a go. I plugged my in newest AMD GPU that I had, a PowerColor 7870 giving me about 2$ a day. Then soon I discovered that I had a 5850. Soon after I tried to plug it in and hoping it was just plug-and-play, but no. When I first booted up and tried mining one of my cards only showed up. I was so frustrated after trying to fix the issue for 1 week I decided to screw it and start over. I got it to detect the card, but not actually mine anything. It kept giving me "Insufficient data" Or something along those lines.

What software am I using? I am using claymores cash GPU miner

Do I have enough power? Yes I do, I have a 750-watt corsair PSU

What OS am I using? I am using Windows 10 64bit

Anyone have any idea how this issue can be fixed? I mean like it's a mystery I have tried everything that I can think of.
Thanks!

I am willing to bet its a driver mismatch, what version driver are you running?

run just the 5850 solo, does it work? if no then it is the driver.... per amd the driver for the 5850 is 15.7.1 and you are in luck the 7870 will run on that version as well.

Run the AMD DDU in safe mode for a clean uninstall, and install 15.7.1....

I would suggest downloading it before you uninstall what ever driver you are using, unless you are using 15.7.1, then