Installing on Debian Stretch

Hello everyone,

I just made a fresh install of Debian 9 (Stretch) and wanted to install the Zcash client on my new machine. Installation procedure here says:

"Add the repository to your sources:
echo “deb [arch=amd64] https://apt.z.cash/ jessie main” | sudo tee /etc/apt/sources.list.d/zcash.list"

Because Stretch now has become stable, I added the repository to my sources, but replaced “jessie” by “stretch”.

When I started the installation this gave me lots of error messages “could not find yx”

  • How can I run the client on Debian Stretch?
  • Will there soon be a repository for Stretch?
  • Can I replace “jessie” by “stable” in the sources?

Any help would be really appreciated, THANK YOU :slight_smile:

1 Like

I just added the repository "deb [arch=amd64] https://apt.z.cash/ jessie main" on my Debian stretch machine, did an "apt-get update" and installed zcash from that repository. Worked like a charm.

However, I would propose that the repository should be renamed to "deb [arch=amd64] https://apt.z.cash/ stable main".

1 Like

Can you file a ticket on Github about renaming the apt repository? Thanks.

2 Likes

To be clear, is the binary from apt.z.cash safe to run on Debian 9 (“stretch”, “stable”)? While waiting for the official word from the GH ticket #3456, I ask the community… Are many people using the “jessie” .deb on stretch? Or is all users of apt.z.cash still running Debian 8 “jessie” (“oldstable”)?

Reconfiguring servers here. I want to finally be rid of the jessie installation I keep only for zcashd, due to the apt.z.cash dist being named “jessie”. When using money handling software, I want to be safe. But jessie is too outdated for any other production use here; and jessie is not anymore getting regular updates. It would be nice to get Zcash running on the current Debian stable before upgrade to Zcash 2.0. :wink:

Thanks for any community insights about this.

This is now critical, as there is a code execution vulnerability in the apt updater that is apparently not being fixed in jessie. Therefore, jessie cannot be safely updated anymore!

https://www.debian.org/security/2019/dsa-4371

Is everybody still running zcash on jessie? (Is anybody still running zcash on jessie?) Is stretch officially supported from the apt.z.cash repo? I have not seen any documentation of this issue, and it is still “jessie” under dists. https://archive.is/KS4oF

I’m using it on Stretch (9.7), no problems here…

1 Like

“jessie” in the description actually means “jessie or later”. I’ll see if we can clarify this somehow.