Introducing Zepio Wallet

New wallet application! Here’s the blog post, which I will also copy-paste below: https://www.zfnd.org/blog/zepio-wallet/


The Zcash Foundation is delighted to announce Zepio Wallet, a shielded-first, cross-platform Zcash wallet that includes a full zcashd node. Sync and spend to your heart’s content! (Or sync and save. It’s up to you.)

Zepio is currently available for macOS, Windows, and Linux. You can download the latest version on the GitHub releases page.

Zepio was built by André Neves and Astrocoders. The team also created Zepio’s documentation and website. Neves wrote about the technical choices and development process that shaped Zepio Wallet.

As with all other Zcash Foundation software, Zepio Wallet is open source. Specifically, the code is available under a standard MIT license. (Neves explained that “we purposefully chose libraries, frameworks and packages that follow the same set of OSS principles” that have long been valued by the Zcash community.)

Zepio Wallet joins ZecWallet as a desktop Zcash wallet with the important features that we’ve highlighted in this blog post. Both are financially supported by the Zcash Foundation. The Zcash ecosystem benefits when there are multiple user-friendly applications that enable easy usage of shielded Zcash (including the improvements brought by Sapling).

It is exciting to see the options expand, and to help lay the groundwork for continued Zcash adoption!

12 Likes

I have got to test this. I wonder if sync speed is faster. Great job :slight_smile:

P.S. Just downloaded it, and I get this error, what do I do? I am on Windows 7

P.P.S I tried deleting anyting related to old Zcash wallets and parameters from %appdata% folders, uninstaling Zephio and installing it again, and I get the same error.

3 Likes

Try the troubleshooting guide: https://zepiowallet.com/troubleshooting

Let me know if that doesn’t help, and I can ping André to take a look.

2 Likes

I did try deleting the parameters already as i wrote it in my post. I would like to hear if anyone else tried it and if it works for them.

1 Like

Ill try later tonight on win7, letya know

1 Like

I just tried on Linux and can replicate this error. Nothing of interest in the logs either. I also renamed the existing .zcash dir and that was successfully recreated with a fresh new zcash.conf file.

{"error":false,"status":"Downloading network params, this may take some time depending on your connection speed"}
Fetching params
Zcash - fetch-params.sh

This script will fetch the Zcash zkSNARK parameters and verify their
integrity with sha256sum.

If they already exist locally, it will exit now and do nothing else.

{"error":false,"status":"Zepio Starting"}
Already is running!
3 Likes

It works with an external zcashd but doesn’t seem to want to start an embedded zcashd as presumably as per the logs above it thinks it is already running (which it isn’t).

I created an issue here: https://github.com/ZcashFoundation/zepio/issues/131

4 Likes

Thanks for confirming its not just Windows.

2 Likes

Hey guys! Thanks for testing the app. We’re received @garethtdavies’ comments and issues and we’re looking into it now. Bear with us as we fix these kinks. Appreciate the feedback and support.

4 Likes

I’m running the MacOS version. Looks good. Although, the default transaction fee is 0.001 ZEC (about 8 cents). Shouldn’t it be 0.0001?

3 Likes

Yes. We apologize for this nuanced mistake. There’s a fix about to be merged and released.

3 Likes

v0.7.1 released: https://github.com/ZcashFoundation/zepio/releases/tag/v0.7.1

It addresses some of concerns related to fee value, testnet switch and missing debian dependency. We’re actively debugging the zcashd node, and hope to push a couple fixes soon, but wanted to get these urgent things through quickly.

5 Likes

Released: https://github.com/ZcashFoundation/zepio/releases/tag/v0.7.1 :slight_smile:

3 Likes

I downloaded the new version, still get the same error. Maybe its best to test it yourself on a brand new lap top/ PC with freshly installed windows/linux that hasnt had zcashd downloaded before.

1 Like

I updated that issue as for me I had a running zcashd in a Docker container that it was detecting. Stopping the container and it worked as it should, so I suspect it is detecting a running process of zcashd for you too somewhere… I’m guessing a fix here is simply to check if the process is indeed running inside of a container (though that might be intentional to connect it to Zepio so it’s tricky).

2 Likes

Latest 0.7.2 release contains a fix for this so give it a try :+1: : https://github.com/ZcashFoundation/zepio/releases

2 Likes

Hello, tell me where the wallet file is stored, and whether it is possible to transfer the file from the old wallet (wallet.dat)

It’ll use the existing wallet.dat (as it’s essentially a nice wrapper for zcashd) and it by default stores it in the same location so if you haven’t specified a custom datadir that’s

Windows: %HOMEPATH%\AppData\Roaming\Zcash
macOS: ~/Library/Application Support/Zcash
Linux: ~/.zcash
2 Likes

Thanks you :+1: (20 characters)

2 Likes

0.7.2 solved my installation issues. Just started sync, lets see how long it takes me. First impression, I love the design, and I wish I could set up password to access my wallet.

2 Likes