Zec-qt-wallet now comes with embedded zcashd

zec-qt-wallet v0.3 now ships with an embedded zcash daemon on Windows and Linux!

At startup, if zec-qt-wallet cannot connect to an external zcashd, it can start the embedded zcash daemon using your existing zcash.conf.

For first time users, zec-qt-wallet will additionally

  • Create a new zcash.conf with a random password
  • Download the zcash sprout/sapling params (~1.7 GB download)
  • Start (and then stop) zcashd

Download here: https://github.com/adityapk00/zec-qt-wallet/releases

Please let me know if you have feedback, issues and/or feature requests!

More screenshots:

image image


Awesome :+1:

If you are using WinZEC and want to test this then you can simply download and start it up and it’ll use all the config/blockchain/wallet stuff - essentially you are just replacing the front-end and the bundled zcashd instance.


If you mean RPC password, note that cookie authentication has been supported for some time now, so you can instead rely on being able to read the cookie file (created on zcashd start) from the datadir.


Oh? I didn’t even know that! Let me look into it!

I am on fedora 28 on 4G RAM and sufficient empty disk space. Following the official zcashd instructions, I got beyond the github download but the build has many errors. I then tried your qt-wallet. Unfortunately, after about 6 hours, I remain at “syncing, 67%”. I hope to be able to run a node on the official zcashd software and have this qt wallet running as well. Any tips to install and run a node using the official version - would be most appreciated.

What is in your zcash.conf file? It’ll be in ~/.zcash/zcash.conf is there a line addnode=mainnet.z.cash as this was missing from an earlier release and will help in bootstrapping finding nodes? Does the embedded zcashd in zec-qt-wallet show you have any connections?

Edit: related https://github.com/zcash/zcash/pull/3670

1 Like

4Gb is kinda low, my old laptop struggled until I gave it more memory - works great with 8Gb.


Hi - tks for your suggestion. The file had the addnode=mainnet.z.cash line - the qt-wallet was able to connect and sync - the process stalled at 67% The related link is to the official zcashd github - I would need to see when the Qt version embeds this new zcashd version; alternatively, overcome the build errors, build a working official zcashd then come back to the Qt version and have no reason to use the embedded zcashd - I am wondering if anyone has successfully built zcashd on Fedora 28

@ChileBob my aim is not to mine - just run a node and transact. Would this really need even 4GB of RAM?

I think yes, but that’s just my humble opinion.

I don’t mine on my old laptop, its just a node & a playpen for various projects but it really had a hard time until I added the memory - the slow hard drive didn’t help either.

My theory is it validates blocks while its syncing & that’s where the extra RAM was needed - didn’t cost much & sure fixed my problem.

1 Like

Is there anything in your debug.log file at ~/.zcash/debug.log

How to remove wallet on Mack what locations i need to delete

17.02.2019 13:39:20 =========Startup==========
17.02.2019 13:39:20 Found Zcash params directory at C:/Users/Insert Coin/AppData/Roaming/ZcashParams
17.02.2019 13:39:20 Found zcashconf at C:/Users/Insert Coin/AppData/Roaming/Zcash/zcash.conf
17.02.2019 13:39:20 Attempting autoconnect
17.02.2019 13:39:22 Trying to start embedded zcashd
17.02.2019 13:39:22 Embedded zcashd started up, trying autoconnect in 1 sec
17.02.2019 13:39:23 Found Zcash params directory at C:/Users/Insert Coin/AppData/Roaming/ZcashParams
17.02.2019 13:39:23 Found zcashconf at C:/Users/Insert Coin/AppData/Roaming/Zcash/zcash.conf
17.02.2019 13:39:23 Attempting autoconnect
17.02.2019 13:39:24 Authentication failed

Erased zcash.conf, disinstall, reinstall. It worked.


1 Like

and whats the total download size of synchronizing data(blocks) as of Feb 2019 for Linux machine?

From https://docs.zecqtwallet.com/faq/#how-large-is-the-blockchain it’s about 22GB.