Issues with Mobo ASUS H170 pro gaming : can't detect 6 GPUs

I decided to build a new rig, and was struck by a compulsive buying disorder : instead of going for a standard asrock BTC PRO, i bought a skylake Asus H170 Pro Gaming Mobo along with a Intel Core i3 6100, 6 GPUs and a PSU big enough to power everything
.
My problem is the following : no matter what Os i use (tried Win10 / xubuntu 15.10 / xubuntu 14.04), my mobo is unable to detect all my GPUs. At best i got 4 GPUs working on each OS.

This error showed up in the device and hardware monitor : This device cannot find enough free resources that it can use. If you want to use this device, you will need to disable one of the other devices on this system. (Code 12)

I've also tried to change the Mobo's BIOS, without any noticeable changes. I checked my risers one by one, no problem on this side.

In bios change pci-x to gen 1 this should free up some bandwidth for you also if using windows 7 u will need to use the free tool to enable more than 4 GPU just google win7 GPU fix for more than 4 cards,open up watman and disabled crossfire and then reboot you might have to do the reboot a couple of times to get cards recognised windows can be stubborn sometimes.

I have an Asus Z170 Pro Gaming Mobo (same as yours just the Z chipset) it only detects up to 4 GPUs which I am running fine.

These boards are the biggest hassle to get multiple pci-e 1x risers to run in between all the other bios hassles and random problems, the good thing is I only run 4 GPUs per rig but have tested and anything more is no go sadly.

Why do people keep buying this MOBO for mining? It's chipset is horrible and it's not very cost effective either.

1 Like

Which motherboad do you all recommend for skylake?

Z97 Gaming 5 it's good option

That is for LGA1150 socket. I need one for LGA1151

Either keep your Skylake CPU and make a gaming PC or sell it and buy a cheap Celeron G1820 for $40 and the Z97 Gaming 5 for a mining rig.

I've just signed up to let people know I've been successful in getting 6 GPUs to work with the Asus H170 Pro Gaming motherboard, here's how I got it to work (after much reading and trying different things):

  • Update to the latest BIOS
  • Enable new setting in BIOS "Above 4G Encoding"
  • Installing Windows via UEFI, not the standard MBR version (easily done with a little application called Rufus to create a UEFI bootable USB)

Hi Keydogg,

I am having the same issue. 3 cards work but more than that fails. I tried your "4G Encoding" setting that made at least to show bios, but loops from there.

I actually installed using bootable USB and UEFI option is enabled by default, i have everything set up so I do not want to reinstall windows 10 again. Not sure what else I am missing in the BIOS. I really appreciate your help on this.

Hi Tesar,

If you're getting bootloop then it's more than likely you haven't actually installed the UEFI version of Windows 10, rather the MBR version. The way to tell is if you boot into Windows and go to disk manager, there should be 4 partitions on the drive disk with UEFI each called Recovery, System, MSR and Primary.

If you have windows installed via MBR, there will be 2-3 partitions only.

To install UEFI you need to use a little app called rufus to create your Bootable USB, there is a drop down box on there to make sure it's a UEFI install.

I hope this helps!

I hit a roadblock installing the UFEI windows.

I followed these instructions http://windowsreport.com/install-windows-10-using-uefi/ created USB with UEFI but got stuck at step 'click on the “UEFI Firmware settings”'. I dont see that option and I am using windows 10 pro. Even I tried to boot into my USB drive but I get nothing just the black screen.. I tried various options but no luck. Not sure how you got through all these steps. Thanks

Basically. Turn off 4g encoding until you manage to install Windows UEFI.

Download Rufus + Windows 10 ISO
In Rufus select USB drive
Select "GPT partition scheme for UEFI"
Select Windows 10 ISO that you are using
Let Rufus do it's thing
Reboot and boot from USB
Reinstall from USB (it will create 4 new partitions if you delete all old partitions and create new)
Once Windows is installed, enable 4G encoding and you will be able to boot into windows and see 6 GPUs :smiley:

Thank You so much..

Have been on call with Asus rep, but he could not figure out. I will try that again and see how it goes.

Asus rep told by default install is UEFI :slight_smile: and what I am running is UEFI install, otherwise he says I should not see the UEFI BIOS.. But you know much some rep's know :slight_smile:.. let me try once more, will update you

Select "GPT partition scheme for UEFI" really did the trick. It let me reinstall windows. Thanks again.

Though I see it got stuck at blank screen on booting with all GPUs for a while. I had to hard boot multiple times, probably I am being impatient after all this :slight_smile: . But when it finally came up it all worked!!! :relieved:

No problem!

By the way you will always see the UEFI bios whether windows is installed via UEFI or not so the Asus rep was getting a bit confused hehe.

Glad you got it sorted out!

Hi. I resolvet this problem whit ASIS H170 pro gaming. Here is manual to seting bios and resolve problem whit code 12 in windows 10 :slight_smile: You must have 64-bit version OS.

Hi Toni I guess I got a broken board I did everything you did besides what @Keydogg mentioned but no success at all. I get black screen right after bios post. It happens no matter what I do but enable 4g decoding.

How do you own your processor? And did you connect your monitor to the first PCIe graphics card?

I had the black screen also and it was because Windows 10 wasn't installed the UEFI way, it was installed via the regular MBR installation (which is how every windows installation has been done in the past unless specified). The MBR for windows will not recognise the 4G decoding because it doesn't have the memory allocation to allow for it.

Follow my instructions above to reinstall windows via UEFI and you will be fine :slight_smile: