macOS support for zec-qt-wallet is here!


#1

I wanted to announce that macOS support for zec-qt-wallet is finally here!

zec-qt-wallet now has full macOS support, including the embedded zcashd, sapling turnstile, z-board.net integration and everything else that’s available on Windows and Linux.

Download here: https://t.co/b7H0TTfm0i

(Special shoutout to @rex4539 and @garethtdavies for extensively testing zec-qt-wallet and being very helpful with feedback!)


#2

Thank you so much for this important contribution to the Zcash community.

When I try to create a new z-Addr, it warns me that I am about to create a Sprout address. How do I configure the software to generate a Sapling address?


#3

Is your node synced? The ability to generate Sapling addresses is only shown in the GUI once Sapling is active and then you should see something like this?


#4

No, my node isn’t synced yet. Thank you so much @garethtdavies for your help.


#5

I’m trying to get it running with an external node running on dedicated server without success.

I can’t get the app running with --no-embedded argument … Did anybody succeed with this ?

EDIT: OK, I got it running by doing with Apple Script:

do shell script “/Applications/zec-qt-wallet.app/Contents/MacOS/zec-qt-wallet --no-embedded”

Second issue: how to edit /fill the fields in settings “zcashd connections” ? Shall we write something specific in the zcash.conf file?


#6

If you have a zcash.conf file in ~/Library/Application Support/Zcash/zcash.conf, then zec-qt-wallet will read the settings from this file, and disable editing the options in the Settings page. This usually works if you have the node running locally on the same machine.

If you are connecting to a remote node, I recommend you delete the zcash.conf file on your local machine. That way, zec-qt-wallet will let you enter the name/password/host/port in the Settings dialog.


#7

Thanks for the help!
It works: when deleting the zcash.conf file, I’m able to fill in the options in the setting pages (same info as in the zcash.conf on the server:

addnode=mainnet.z.cash
rpcuser=user
rpcpassword=*****
rpcport=63232
rpcallowip=1.0.1.1/24

However, the “Starting Up” window won’t disappear.

Any idea of what could be wrong?


#8

I’m not 100% sure, but my guess is that the remote node is not allowing incoming connections to port 63232. It might be because:

  • zcashd on the remote machine is listening on 127.0.0.1 (instead of on 0.0.0.0, to allow external connections). You can run ps aux | grep 63232 on the remote machine to check.
  • A firewall on the remote node is blocking incoming connections. Check with ufw status

One thing you can do to debug is connect to the remote node with port forwarding using ssh, and see if that works.

#From your local machine (the one running zec-qt-wallet)
ssh user@remote -L83232:127.0.0.1:83232 

And then, in the settings in zec-qt-wallet, change the server to 127.0.0.1


#9

I solved it by modifying the allowed IP… and it works now :slight_smile: