MSI Z270 gaming M3 4G Decoding Enabled problem

Hello friends;

Really need your help!!

When i enabled 4g decoding from bios. I can not boot the windows. There is only black screen. When i disable 4g decoding,i can boot but there is just 3 graphics card shown in system, it works fine.
How can i solve this problem?

I am using MSI z270 gaming M3 motherboard.

Million thanks in advance for quick solution.

How many gpu's in total?
When you installed windows did you install it under UEFI?

Thank you for kind reply.

I have 6gpu (RX 580), and i install window just in express setting.

express settings when configuring windows is not the same as UEFI in the bio settings when setting up the HD and installing windows

in the bio's do you have your pcie set to gen1?

Yes I do made it to GEN 1

With three gpu's and 4g off, it will boot and windows see's all three cards? drivers installed?
What version of windows are you running?
Are you sure you installed windows under UEFI?

Click here to for instructions to check, option one should is all you need to do to verify, if you're still not sure try option two.

Correct. With three gpu's and 4g off, windows is booting and three cards are working with drivers installed.
I am using windows 10 pro.

Now I will follow ur instructions and will install window once again under UEFI.

I have installed the window under UEFI. but still same problem when i enable 4g window doesnt boot only black screen come.

Pls help

does it boot with 3 or less gpu's installed

What is your bio's version?
Did you make the needed changes to your system variables and system virtual memory size?

When I putted 3 gpu and 4g and Gen1 is off. window boots but when i turn on gen1 and 4g, window doesnt boot its shows black screen only.

I flashed bio withVersion
7A62v12
Release Date
2017-03-31
File Size
7.33 MB

Now with 3gpu 4g on gen1 on, it boots to window but only 2gpu detecting.

@CitricAcid do you have whatsapp number, if u can help me, really appreciate

i have the same problem with msi z270 gaming m3 any solution ?

No buddy still didnt find any solution.

I don't have this board so I don't have detailed instructions to give you on each settings to change in the bio's -- another suggestion would be instead of Gen1 switch to Gen2.. there are usually a couple of places to change it

if you are running a 64bit O/S
have it partitioned under a GPT and not MBR, and its installed under UEFI
ran all of the updates
had 4g off switcg to either gen1 or gen2, installed the first card, loaded drivers, restarted, tested mining program everything works, shut down, installed second card, tested - works, install 3rd card - tested works- shut down - switch to 4g - install 4th card - turn on... it should work

Well I have tried all the methods. window is booting with 4g and gen1/gen2, however only 3gpu detecting.

I thinking to buy other motherboard. could you suggest Mobo?