Stuck at BIOS screen after adding more than 3 GPU's

Greetings,

I'm running into trouble while building a rig with this config :
- ASUS H270 Plus
- 1x nitro+ rx 470 8gb
- 3x amd radeon rx470 4gb
- 2x MSI radeon rx470 8gb
- 1200W corsair power supply
- 4gb DDR4 ram
-windows 10 pro *64

I have setup the PC installed 1st then 2nd then 3rd GPU no problem everything was running fine. Then when I tried to plug the 4th GPU onward my pc get stuck after BIOS screen (black screen with blinking cursor top left corner) after few seconds the PC restarts and keeps doing the same. Some times i get warning saying that no keyboard is detected. I have tried changing PCI slots, changing the risers, plug different GPU its always the same 3 runs with no problem once the 4th plugged the problem happens.
I have already updated the motherboard BIOS, enabled 4g decoding, tried to increase the ram to 8GB still the same.

Any ideas?

Thank you

Have you set the PCIE bus to GEN1 ?

yes i did that already, still same issue

Well, if you have a 1200w psu, that isn't the issue...fully running you should pull around 900w-ish.

I believe I remember reading to make sure you have updated the bio's to the latest version (which you said you did), TURN OFF 4g decoding!!, get each card installed and no errors in device manager, then turn 4g back on

you can see @cryptomined post here

do you mean i install them individually then combine them?

first i'd test each card individually (label each card #1, #2 and #3. Then I'd proceed as follows, assuming that #1 works well:

install #1 and #2
boot, test
if all goes well, remove #2 and replace with #3
if turns out ok, remove #1, test #2 and #3 together
that would help you at least to ensure that all cards work together, until you get to the point where you need the 3 cards working alongside.

I'm having the exact same problem. ASUS H270+ board and can't get past 3 gpu's. Did anyone figure out how to fix this apparent irc conflict?

Hi there. Have you finally got this working? I’ve got exactly the same motherboard and having same issues. Thanks.

  1. unplug all the risers
  2. reset bios (remove the battery)
  3. reconfigure bios
  4. boot
  5. shutdown
  6. plug in risers
  7. boot

This has happened to me a few times … this is how I have fixed it every time…

IMHO That cursor is usually because sometimes the bios gets reset when you add GPUs.

1 Like

Thanks for the tips. I will give it a try tonight. I sincerely hope it gets fixed with just doing that! Will write if I finally got it or not. I will be surely useful for other people :smiley:

I finally tried all the above and none worked. I finally got up to 4 GPU’s working (1,3,4,5) but the 2nd PCI-E is not working when using other PCI-E.

I’m going to RMA the mobo :frowning:

The problem is low amp’s voltages. try to plug the power supply with the main electric socket where you on Air conditioner or heavy voltage socket. I had the same issue even I have been using 10k watts Voltage stabilizer that was showing full voltages, but finally easily resolved it by just changing to main power supply to the high voltage sockets.

go to asus website, download newest bios > update bios manualy.

do not update bios through bios updater. its gets older update than should