My z-address seem to be invalid!

Hi,

I have a long z-address generated with 1.0 wallet but:
- When i look on zchain, it say my address are invalid
- I have mined on a pool, 2 payments sended but nothing in my wallet
- When i try to add my address to suprnova, i got "invalid address"

What i can do ?

I think, as I have the same problem, we need to use the t-addresses, despite the instructions at https://github.com/zcash/zcash/wiki/1.0-User-Guide which read in part:

`To get a list of all addresses in your wallet for which you have a spending key, run this command:

$ ./src/zcash-cli z_listaddresses`

as no t-addresses appear in this list, I assumed I have no spending key for them... and there's no analoguous t_listaddresses or even listaddresses command that worked for me.

Presently I have the option of providing a t-address to Poloniex, with no reassurance I can spend it.

Please help resolve this ambiguity.

Yes you need to use t-address... The guide are not clear about that.

Your t-address is active?
Did you received any payment?

Yes, i mined with my z-address and pool owner tell users to send t-address.
He's converted Z to T in his DB and i finally got payments

Another pool refused my z-address when registered. Put t-address and it's worked.

You are kind and generous. I'd say the guide is misleading, though clearly, not deliberately or maliciously.

I gave the exchange a t-address and the ZEC arrived.

Now what? https://github.com/zcash/zcash/wiki/1.0-User-Guide speaks eloquently of sending ZEC from z-address to z-address but gives no help on sending from t- to z-

Like earlier users I'll have to guess that I have keys, and that "address" means both/either z or t addresses are acceptable.

Hamish.

Similar issue here
Genrated a t-add and z-add using native zcash app.
Got New Hardware
formated system (linux system so home directory is intact no changes to conf files).
Mined somewhat.
Pool transfered 0.01zec but not received in my wallet.

zcash-cli gettaccount "t-add"
no output

zcash-cli listaccounts
{
"": 0.00000000
}

zcash-cli importaddress "t1TjjzfFSv4hLbPs6TYTq9fDcbdnctAdhxz"
error code: -4
error message:
The wallet already contains the private key for this address or script

zcash-cli setaccount "z-add"
error code: -5
error message:
Invalid Zcash address

zcash-cli setaccount "t1TjjzfFSv4hLbPs6TYTq9fDcbdnctAdhxz" "z-add"
error code: -11
error message:
Accounts are unsupported

zcash-cli z_listaddress
my z-address

The restriction for mining pool payouts to t-addrs is not a Zcash limitation, just a preference for operators so it doesn't make sense to put into the official Zcash guides.

And that User Guide links to the payment api which should help you understand how to use both t and z addrs. Let us know if something is not clear in that document.

went through that page and tried few things
validateaddress shows t-address as valid
and z-add as invalid

importkey "t-add"
spending key is invalid
error code -1

zcash-cli z_importkey "t1TjjzfFSv4hLbPs6TYTq9fDcbdnctAdhxz" [rescan=true]
error code: -8
error message:
rescan must be "yes", "no" or "whenkeyisnew"

cash-cli z_gettotalbalance "t1TjjzfFSv4hLbPs6TYTq9fDcbdnctAdhxz"
error: Error parsing JSON:t1TjjzfFSv4hLbPs6TYTq9fDcbdnctAdhxz

in all i don't get how could my address change if i didn't deleted or changed my wallet or any conf files.

just after posting this i checked my swing wallet and it showed my balance (yippeee)
and there are 3 t-address and one z-address. is there any problem with having 3. and mining on first one only.
it would be great if you could shed some light what happend here.
I am new to crypto and read alot but yet not fully understands everything