New Rig Build, Monitor says no signal from the computer

Hi everyone,

I recently build a rig, with GA H110-D3A, 1600WPSU and Nividia GTX1700.
I didn’t have a VGA to HDMI cable to connect the monitor so I opted to use display port to display port mini, and I plugged it in one of the rigs to the monitor.
The monitor recognizes the rig, but it says’ no signal from the computer, try pressing f2 to boot’ or something similar. i tried clicking the mouse or pressing F2 but no response.

Any thoughts on this? any help would be appreciated.

Hi man!
Something similar happened to me when I built my rig.
The right way to do it is to install ONLY one of the vga’s and make sure everything works, install the driver, etc. After that try the second card and so on.
That’s how it worked for my 3 1080’s.
I currently have the monitor plugged to onboard graphics which is very convenient if you want/need to use the pc while it mines and don’t get the whole system clogged up in the process.

Try that out and let me know if you need any more help. Also check the bios for any mining/multi gpu compatibility setting option (I have that on my mobo) and once you get to windows don’t forget to set virtual memory to 16gb.

Hope all these helps! :slight_smile:

1 Like

Hi there!

thanks for the swift response!
I followed your advice and I finally got to install windows on my other rig! The first one that I was working on still couldn’t get any signal on the monitor… I wonder if there’s anything to do with the motherboard or the psu?

Where is the monitor plugged in ?

it’s to the display port of the gpu to display port mini of the monitor. this method worked on my second rig. i tried plugging into different gpu but still no signal for the first one.

Can you try on the motherboard display ?

I had similar problem. I connected HDMI cables to each GPU used them as dummy and only one to Monitor, then rebut the rig several times. Try it. Let me know if it works.

You’re welcome!!
I’m glad I could help :smile:
Regarding the rig you can’t get to work, I think it might be more motherboard related. I am not saying it’s faulty just that it might need some tweaking to recognize the video card. Have you tried installing the vga without the riser? Riser cables can cause trouble some times.
If it was the psu you’d experience reboots and a unstable system but that’s something you would experience once in the os and while the vga is loaded with work. Here the thing is the signal, there is no info going from the vga to the monitor.
Your monitor only has a mini display port? No dvi, sub9 or hdmi? Do you have anothet monitor or tv to try it with?

it’s plugged into one of the gpus…

i’ll have to go get hdmi cables then…

yea i don’t have other cables with me… only the display port to display port mini…might have to go get cables to try that out.

Can I ask you one more question? How do I get my computer to recognize the gpus?
I did add them on one by one, but the computer only recognize the first two… when I put the third one in, the rig won’t turn on or even go to the bios page.

Hey! You can ask me as many questions as you want :wink:

See, my motherboard’s manual says which pcie ports in particular I should plug vga’s in depending on the quantity. For instance, it said something like “when pcie 1 and 2 are being used 3 and 4 won’t be available” so I went for the 5th…although I have to talk to gigabyte guys as I’d like to install two more vga’s and my mobo was advertised as capable of doing so.

Some mobos need a bios upgrade to be able to hold bigger amount of vga’s , but when it comes to rigs like ours (with 2 or 3 cards) it is more likely to be a config thing what we have to sort out.

By the way, do you have your mobo’s manual?

By the way, you can try to install the 3rd card with one of the other rig’s riser which you know it’s already working.

I added third GPU and my comp did not recognize it. I changed GPU cables then I swap raisers one of them did not worked.
Two GPUs worked fine and Im running in to same problem 3 GPU give me system 32 error and Windows 10 does not recognize AMD drivers.

i do have the manual but there’s not much detailed information about how the pcie works…

now the maximum gpus that device manager could see is 5, is there anything else i can do to make all 7 gpu work? and could i actually run a gpu on a m.2 to sata slot? the gpu’s fan was always running but it’s one of the undetected gpus. Thanks you ao much again for the lengthy response to help me out :slight_smile:

here what i’ve done and my system:

  • enabled 4 g decoding, enabled mining mode, tried switching between gen1/2
    -increased virtual memory
    -installed Asus tweak ii
  • Tested every single raiser to make sure it’s working fine
  • Updated drivers for windows.mobo.and GPUs

and i have these on my system:
OS: Windows 10 pro
CPU: Celeron Gen7 G3930
RAM: Fury DDR4 Ram
SSD: Adata ssd su770
MOBO: Gigabyte GA-H110-D3A Mining board

@silvermoon this site might help. https://www.gigabyte.com/MicroSite/462/mining.html

Hey buddy!!
Sorry it took me awhile to answer this time. I’ve been running around at work and solving some personal issues :stuck_out_tongue:

Okay lets see, the Sata cable for as much as I know is only used to feed electrical power to the risers but no data travels through them.
About the config it looks like you’ve done a lot!
So, the mother says you can connect up to 7 gpu’s? Ot you’re trying to make them work?

Mobo is right, you’ve got the same win as me, we also have a celeron on our rigs and you say you increased virtual mem: is it on 16 gb?
The nvidia driver also recognizes the 7 devices?
Oh and, Its a obvious one but often the most overlooked fact as well when we deal with these things: have you set cuda devices 5 and 6 (would be 6th and 7th)?

I will check out the link @blackwidow left here and see what I got :wink:

Hello again!

Thank you so much for your response and I really appreciate it :slight_smile: I don’t mind the delayed response; i’m grateful that you took the time to answer all my questions…I have a bit more for you tho :sweat_smile:

The GA motherboard on the website says it could support 6 gpus. The reason I thought it could support 7 gpus is that there was news about it on tech sites and on forums. At the end I just bought another mobo that could support 7 gpus to solve the problem. With the new mobo the rig still took time to find the 7th gpu. Do mobos all have difficulties finding the last gpu that doesn’t exceed their limit? Like the GA mobo could support 6 gpus, and so it’ll always have problem finding the 6 th gpu?

The most I got with the GA mobo was 5 gpus. And I almost gave up on installing the 7th gpu even with the new mobo because the rig couldn’t detect it. It only worked after I kept changing the PCIE speed from Gen 1 to Gen 2. does that apply for every motherboards assuming that I set up rig correctly and installed all drivers necessary?

Yes, I’ve increased the virtual memory to 16384mb to 20000mb. I have two 4gb RAM on mobo so there’s 8 gb in total. But I heard Ram doesn’t matter as long as you set the bios correctly right?

The Nvidia driver recognizes all 7 when device manager recognized them. Does it ever go the other way around?

And about the cuda device… what is that actually about? I know that it’s optional to write it in when you’re trying to edit the files on the miner. Besides that I don’t see an option about it on the bios. The information about it on the web is also quite confusing.

Again, words can’t express how grateful i am towards your response. This helped me a lot in understanding the tech stuff that I never took time to learn. Thank you so much :blush:

Thank you! I’ve already checked that out but thanks a lot for the input!