No addresses displayed with z_listaddresses


#1

Following the Public Alpha Guide (as at 5 September) I've been able to compile and test ZCash (no errors for the full test suite and the RPC tests).

I've been able to run the daemon and generate two new addresses with:

./src/zcash-cli zcrawkeygen

The Get Info command shows a connection

./src/zcash-cli getinfo

And the balances were updated once I obtained testnet coins from the faucet (http://faucet.zeropond.com).

However, when running the command:

./src/zcash-cli z_listaddresses

I don't see any "tn" addresses. The output is:

[
]


#2

That means you haven't mined any coins or dont have any coins in your wallet.

./src/zcash-cli getinfo

Should give you a "keypool size" thats how many address you should have (100 is the default)


#4

If I run the command ./src/zcash-cli getinfo it shows that I have '101' as my keypool size and a balance of 0.1.

{
"version" : 110200,
"protocolversion" : 170002,
"walletversion" : 60000,
"balance" : 0.10000000,
"blocks" : 6156,
"timeoffset" : 0,
"connections" : 1,
"proxy" : "",
"difficulty" : 149.97330783,
"testnet" : true,
"keypoololdest" : 1473046705,
"keypoolsize" : 101,
"paytxfee" : 0.00000000,
"relayfee" : 0.00005000,
"errors" : "This is a pre-release test build - use at your own risk - do not use for mining or merchant applications"
}

I still get an empty output when I run the command ./src/zcash-cli z_listaddresses

[
]


#5

What does zcash-cli listtransactions show? (minus the z)


#6

[
{
"account" : "",
"address" : "mhE1MXuBTaoGB4gQ8cwwo5unh9FcA6xX21",
"category" : "receive",
"amount" : 0.10000000,
"vout" : 0,
"confirmations" : 244,
"blockhash" : "671885d28d57aa62046ed8bd55bf5256bc36a2cba426441521254acba75a552e",
"blockindex" : 1,
"blocktime" : 1473047581,
"txid" : "526d957f6dddb0163fe1e9406d27c1cc19366dadac8018f907e06edd1324a4ec",
"walletconflicts" : [
],
"time" : 1473047479,
"timereceived" : 1473047479
}
]

I've been able to skip over this part and get through most of the Public Alpha Guide, but the ./src/zcash-cli z_listaddresses has got me stumped.


#7

Yeah, that part of the guide is confusing to me too. It's essentially asking you to query addresses looking for a tn prefix. Does zcash-cli listaddresses (minus The z) work?


#8

Yes. The output was in the previous post.


#9

listaddresses and listtransactions have the same output?


#10

Sorry, my oversight:

$ ~/zcash/./src/zcash-cli listaddresses
error: {"code":-32601,"message":"Method not found"}


#11

Ok, I figured that the listaddresses command was depreciated, but it was worth a try.
Have you tried skipping that section and creating a RAW transaction using the address you have as the input? Starting at the part where it says run listunspent?

Right now this process is not user friendly, the good news is that the Beta with be getting rid of the complicated RPC interface and hopefully clear up the protect/send/receive process


#12

Hey Hawkeye, I'm right near the same spot with you and was getting non listing for z_listaddresses. I'm on the part of the alpha guide now where I'm just trying to joinsplit the two transactions but I'm getting long delays and hanging on terminal. My syntax might be bad as well, as I'm not using the environment variables as described. Did you have similar hanging isues?


#13

You need the following in the .zcash/zcash.conf file or on the command line

gen=1
genproclimit=4 (for 4 threads)


#14

Okay, so I think I got a bit further, but when I try to joinsplit, it now disconnects from the daemon, and I have to restart zcashd. It's almost there, I can feel it.


#15
  • Elements of w skipped: 671449 (48.66%)
  • Elements of w processed with special addition: 667549 (48.38%)
  • Elements of w remaining: 40739 (2.95%)
  • Elements of w skipped: 571887 (50.11%)
  • Elements of w processed with special addition: 569266 (49.89%)
  • Elements of w remaining: 0 (0.00%)
  • Elements of w skipped: 813806 (48.25%)
  • Elements of w processed with special addition: 809128 (47.97%)
  • Elements of w remaining: 63836 (3.78%)
    error: no response from server

Looks like an insufficient ram issue? Received a bad_alloc error before so thinking this is the case


#16

joinsplits are time consuming and also use extra memory. If you keep a system monitor open during the procedure and notice that all your memory and swap space is being used then your system probably requires more memory.


#17

I was able to mine my first block.

When running the command ./src/zcash-cli z_listaddresses

I still don't see any "tn" addresses and the output is stil:

[
]


#18

how can we use these coins, its hard to transfer them


#19

The Public Alpha Guide has only been partially updated: z_listaddresses only shows a list of private addresses that are in the wallet, and zcrawkeygen merely generates keys; it doesn't add them to the wallet.

You can either generate an address using the new z_getnewaddress API, or use the new z_importkey API to add a key previously generated with zcrawkeygen.

If you use the z_getnewaddress API, you'll need to use z_exportkey to get the private key for use in zcrawjoinsplit. This will not be necessary from beta 1, which will have a new simpler payment API.


#20

Transparent coins that have previously been transacted, such as what faucets provide, can be used just like bitcoin. It's only newly created coin that must first be protected before any other transactions can be done.

The method for handling protected transactions is currently under development.


#21

because the wallet is not provided currently... it is difficult to rely on rpc interface... i am looking forward to a wallet