No connections with zcashd on DigitalOcean VPS


#1

Edit: The guide I was using had me on an old beta version. Current version works.

I did some experimenting with the low end VPS's on DigitalOcean and found that the minimum zcash could be built on there was the 4GB 2CPU VPS running Ubuntu 16.4.1 at $40/month.

Build went fine but after several hours of browsing every guide I could get my hands on, still zero connections.

Has anybody else tried this via Digital Ocean?


#2

i don't think so that the digitaloOcean offer mining cryptocurrenies in their servers.


#3

I have tried, and successfully mined some testnet coins. I was using normal zcashd miner, beta1.


#4

Good to hear. What were your server specs? Did you follow the instructions exactly as described on Github, or did you have to install additional dependencies? Thanks.


#5

I followed https://github.com/Austin-Williams/zcash-guides/wiki/Guide-to-Mining-Zcash-on-Amazon-EC2
with some minor modifications, but nothing huge.
The daemon should run under normal user, and not root. You can use crontab to make sure it starts after reboot.
I'm using one wallet with 10000 addresses, no source code modifications.
I created 512Mb machine, and then resized it to 8GB for building, and then 4GB for running (you have to start from 512 for disk size to be compatible with downsizing).


#6

I would advise against using Digital Ocean for Zcash mining. I have heard that if they find you are mining they will suspend your account without refund, not to mention you will lose all your data.

Section 12 of the TOS: mining = excessive CPU cycles.
https://www.digitalocean.com/legal/terms/


#7

I completely missed that, thanks for warning us :sweat:


#8

In actual practice they remain ambiguous. The last known accounts suspended for mining were a few years ago and it has become quite common since then, although the issue with the TOS was never cleared up. DO took alot of abuse on social media for not allowing mining customers to use all of the resources they were supposedly paying for. But yeah, they have left the door open to stop mining at any moment, so I would say to anyone doing so: Have your backups and alternative services ready for use.

Hopefully that doesn't happen because I've found DO to offer great customer service over the past 3 years.


#9

True, it is at thier discretion how and when they enforce the CPU cycles rule.
I would hate for someone to mine a Block or two only to find later their wallet/account was deleted, not worth the risk IMHO.


#10

As far as I know, DO is still the best price to be found. No risk if you backup your wallet, unless you have other non-mining business on DO that will be shut down in the case of enforcement.


#11

Had the same problem on Amazon EC2 following this guide exactly: https://github.com/Austin-Williams/zcash-guides/wiki/Guide-to-Mining-Zcash-on-Amazon-EC2

Here's my get-info and debug.log: http://pastebin.com/6bLacJRF

Still zero connections. Thanks in advance for looking at this.


#12

At first glance:

2016-10-12 01:31:40 AppInit2: parameter interaction: -externalip set -> setting -discover=0

I was not executing the daemon with -externalip switch, it was not needed on DigitalOcean. Never tried on AWS.

2016-10-12 01:31:40 Bitcoin version v1.0.0-beta1 (2016-09-09 00:41:41 -0600)

You should checkout v1.0.0-beta2 branch and compile from there. AFAIK, beta1 is no longer in use.