Pci-e riser won't power gpu

I’ve got an old Dell Inspiron 530 with a Foxconn G33 M02 motherboard. It has a 16x PCI e slot and a 1x slot. One of my XFX RX 580 cards mines great on the 16x slot, but when I try to run it through a riser it doesn’t seem to get power because the fans never spin and the blue power light doesn’t turn on. I’m afraid the risers are not compatible with the motherboard, but I can’t figure out how to test them. I’m using these https://www.amazon.com/gp/product/B071LQFCN4/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

but these ones didn’t work either (one had a bad trace on the 1x connector, but the other looked fine. got a refund) https://www.amazon.com/gp/product/B00IMYODGS/ref=oh_aui_detailpage_o09_s00?ie=UTF8&psc=1

I have a 1200W power supply http://www.thermaltake.com/products-model.aspx?id=C_00001780

and I am connecting the risers by molex. Some case fans are running off of the same molex so I know the risers have power available. the gpus are powered from the top aswell.

I tried pin shorting, but I can see that the 1x already has the pins shorted.

first THANK YOU for giving good information about your system so that someone can try to help.

Questions:
how many risers do you have?
Looking at the link of the riser you provided, are you connecting molex to molex or using the adapter? (don’t use the adapter)
You have one card and are adding a second?
When the RX580 is directly connected to the mobo it works, so if you connect the riser to the existing 16x slot that the gpu did work on when directly connected does it work?
Are you making sure the power cable to the GPU’s are firmly connected? Asking since you have moved it around.
Can you provide the riser with its own power cable that is not shared with anything else and test?

1 Like

Excuse me for a dumb question, but do you power the card itself (besides the riser) from the power supply?

1 Like

Yes, the GPU requires power as well as the riser. One does not power the other.

1 Like

I have two risers. I want to run two cards. The pcie slots are too close together to use just one riser. Using molex to molex.

I think I have tried connecting one riser to 16x slot (and not the other to the 1x slot) with no other connections to the molex but I will try again tonight in a more systematic way.

The pcie power connection to top of gpu is solid. Molex seems very tight. When the pcie connection is not right there is a red light on top of the gpu, but I’m not even getting that. I’ll try fiddling more with the molex connection. Thanks for your help.

I tried connecting the molex with nothing else on it to the riser with the riser connected to the 16x slot and still no joy. I measured 12 V at various places on the riser so the molex must be connected.

I also measured 3.3V at one of the USB connection points on the riser when I had the 1x connected to the MB and no gpu attached to the riser.

I tried connecting the gpu with no molex, no joy. Both tests were with the pcie power connection to the top of the GPU.

It must be something with the motherboard, I wish I knew what. I noticed that both powered risers use the same design and the USB doesn’t carry all of the PCIe 1x connections. Maybe this motherboard/GPU combo needs all of them, or at least one of the ones that isn’t carried through. I think these unpowered risers will work since they carry all the pins through. https://www.ebay.com/itm/New-PCI-E-Extension-1x-Slot-Riser-Extender-Ribbon-Express-Card-Adapter-Cable/173059113237?epid=2283223825&hash=item284b208115:g:LjAAAOSwdnZaRIqt

if the mobo can’t handle the power will it hurt the gpus? maybe the mobo will be OK since I will only run two cards?

if you are trying both riser in the main pcie slot where the gpu will work solo but not with the riser, then the risers are bad.

What riser do you have? there is a version number on it. If it isn’t 007 or higher that may be the issue or again they are bad

the two different ones I have tried are both version 6. I was just measuring some more voltages and found out that the riser is sending 3.3V to pin 11 on both sides and not to pins 9 or 10 like this diagram indicates it should. http://pinouts.ru/Slots/pci_express_pinout.shtml

I do not have any experience with that cable; I’ve bought 70+ of these and never had an issue. I just bought 30+ risers from version 8 to version 9 to try out. I’ll let you know in a couple of days.

@sameb112 I had also the same problem, and just like @CitricAcid recommends, by using Version 7+ all my problems went away.

Buy new risers, there are now versions that even have a LED to indicate they are powered up OK.

Good luck

thanks. I just got an old gaming motherboard that has 4 16 slots so I think I will switch over to that.