Possible Sync issue after creating full node wallet?

I used to mine zcash for about 4 months. The transactions and balance can be viewed in my Jaxx Liberty account but as I learned recently, Jaxx doesn’t like these small transactions. They told me I needed to create a full-node wallet.

I downloaded and installed zecwallet fullnode. During the initial sync process, but before it completed, I was able to import the private keys. My full balance does show up in the new wallet, but the sync never completed. It looks stuck at 82.4% and it hasn’t moved in over a day.

I did some research on this site to see if there was an issue. I found about the rescan option so I did that.

I ran zcashd from the command line so I can view the status. Something is happening, very slowly, but I don’t know how it relates to syncing.

 Downloading blocks | 966422 (1106245 headers) / ~1106250 (87%)
 Next upgrade | Canopy at block height 1046400, in around 69 days
 Connections | 8

Network solution rate | 6.323 GSol/s

Since starting this node 1 hours, 35 minutes, 3 seconds ago:

  • You have validated 2207 transactions!

I am seeing slow progress here … number of transaction validated increase over time. I also see that the headers are very slowly increasing. I am at 1106250 of 1106250 right now, but the bloack hasn’t changed at all.

Really all I want to do is get rid of this. I hoped to send it to my coinbase wallet and be able to sell it from there, but when I try I get the message saying this will take a while. It’s been a long while and I’m not sure if anything is ever going to happen.

My balance is only .9025 coin. Do I just need to be patient longer or am I doing something wrong?

I really appreciate any advice offered.

@daira would a succinct blockchain help in addressing these sync issues? I think it will also help user/wallet onboarding.

Hi shaggybrown, this sounds like the problem that’s fixed by PR 4935, which should be merged to master within the next few days. It will then be included in the next release.

If you’re able to build from source, you could try building and running that PR’s branch and see if it fixes the problem.

Thanks all for the responses. After a few days of no progress, I ended up killing the process and restarting with a reindex and that solved my issues.